myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Werner Punz <werner.p...@gmail.com>
Subject Re: [GSoC][MyFaces on Google App Engine] JspRuntimeLibrary Problem
Date Fri, 15 Jan 2010 11:22:00 GMT
Matthias Wessendorf schrieb:
> On Fri, Jan 15, 2010 at 11:28 AM, Jakob Korherr <jakob.korherr@gmail.com> wrote:
>> Hi,
>>
>> Just a few ideas:
>>
>> 1) MyFaces 1.2 requires java 1.5 or later, JSP 2.1, JSTL 1.2 and a Java
>> Servlet 2.5 implementation [1] and I'm not sure, if Tomcat 5.0.28 provides
>> that.
> 
> 
> nope:
> 
> http://tomcat.apache.org/whichversion.html
> 
>> 2) JSF 1.2 uses the unified expression language, which also includes
>> javax.el.ValueExpression, so maybe you have to provide the implementation
>> for this manually (commons-el.jar) or there's a class loading problem that
>> causes the null value.
>>
>> Another thing: You could try to run it with facelets. Maybe this will work
>> and help you solve your JSP problem.
> 
> isn't there a fallback on older containers to use facelets instead (w/
> MyFaces 1.2.x)
> 
>> Also using Facelets would not be that bad, because JSF 2.0 supports them
>> out-of-the-box anyway.
> 
> JSP is dead
> 
Its not dead, but it is smelling already really badly...

Sorry for digging out that old joke ;-)

Werner


Mime
View raw message