myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leonardo Uribe (JIRA)" <...@myfaces.apache.org>
Subject [jira] Updated: (MYFACES-1896) FacesConfigurator version check incorrect
Date Wed, 04 Nov 2009 01:09:33 GMT

     [ https://issues.apache.org/jira/browse/MYFACES-1896?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Leonardo Uribe updated MYFACES-1896:
------------------------------------

       Resolution: Fixed
    Fix Version/s: 1.2.8-SNAPSHOT
         Assignee: Leonardo Uribe
           Status: Resolved  (was: Patch Available)

I have checked the code proposed and committed a variation of this patch. The regex committed
is this:

    public static final String REGEX_LIBRARY = "((jar)?(besjar)?(wsjar)?(zip)?)?:(file:.*/(.+)-"
+
            "(\\d+)(\\.(\\d+)(\\.(\\d+)(\\.(\\d+))?)?)?(-SNAPSHOT)?" +
            "\\.jar)!/META-INF/MANIFEST.MF";

some additional constants were added, and the testing code was moved to a test class.

> FacesConfigurator version check incorrect
> -----------------------------------------
>
>                 Key: MYFACES-1896
>                 URL: https://issues.apache.org/jira/browse/MYFACES-1896
>             Project: MyFaces Core
>          Issue Type: Bug
>    Affects Versions: 1.2.2
>            Reporter: Hilbert Schraal
>            Assignee: Leonardo Uribe
>             Fix For: 1.2.8-SNAPSHOT
>
>         Attachments: MYFACES-1896-v2.patch, MYFACES-1896.patch
>
>
> The FacesConfigurator does some checks on whether there are multiple versions of Tomahawk
and MyFaces in the classpath. This check is incorrect, in the sense that it can, and will,
log incorrect error messages.
> This problem occurs when using the jar from the tomahawk-facelets project (http://code.google.com/p/tomahawk-facelets),
of which I'm one of the maintainers. The current release is called tomahawk-facelets-1.1.6.2.jar,
which gives the following error:
> ERROR FacesConfigurator?:404 - You are using the MyFaces?-package : tomahawk in different
versions; first (and probably used) version is : 1.1.6, currently encountered version is :
facelets-taglib. This will cause undesired behaviour. Please clean out your class-path. The
first encountered version is loaded from : file:/G:/Development/IdeaProjects/blokart/out/exploded/blokartWeb/WEB-INF/lib/tomahawk-1.1.6.jar.
The currently encountered version is loaded from : jar:file:/G:/Development/IdeaProjects/blokart/out/exploded/blokartWeb/WEB-INF/lib/tomahawk-facelets-taglib.jar!/META-INF/MANIFEST.MF
> However, this jar just contains taglibs and some supporting class files. So the error
is logged without a valid reason.
> I've looked at the code in the FacesConfigurator and have seen that the checks can be
improved, e.g. using the following regular expression for getting the version number of Tomahawk:
tomahawk-(\d\.\d\.\d)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message