myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <ma...@ops.co.at>
Subject RE: [orchestra] latest code in core project is not JDK 1.4 compatible
Date Wed, 14 Oct 2009 06:00:28 GMT
Hi!

Even if you advertised at the beginning, I too think that JDK 1.4 compatibility is no longer
a must.
Merging core15 might then be the logical step.

Are you going to volunteer? ;-)

Ciao,
Mario

Von: Leonardo Uribe [mailto:lu4242@gmail.com]
Gesendet: Mittwoch, 14. Oktober 2009 01:21
An: MyFaces Development
Betreff: [orchestra] latest code in core project is not JDK 1.4 compatible

Hi

Checking some stuff in orchestra, I have seen that some code in "core" project is not JDK
1.4 compatible.

The question is given JDK 1.4 has reached its end of service life, shouldn't we move forward
and make orchestra JDK 1.5 and upper compatible? That means also merge core15 code with core.
Note that if this is not true, we have to change/revert some code already committed to make
it JDK 1.4 compatible (for example, do not make the call to ThreadLocal.remove() on FrameworkAdapter).

regards

Leonardo Uribe

Mime
View raw message