myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan-Kees van Andel <jankeesvanan...@gmail.com>
Subject Re: [Trinidad] JDK5 EOL, upgrade to JDK6?
Date Fri, 19 Jun 2009 18:34:02 GMT
Do you mean the @Override annotation on interface implementing
methods? Yeah, that's annoying.

But IMHO no reason to force users to move to JDK 6. The companies I
see, are currently using 5 (some even use 1.4).
What feature of JDK 6 do you want to use? Besides the (Concurrent)
Collections API I don't know any features that are of much use for
Trinidad.

I think it's very important for any software library to keep its users
happy. Forcing users into a new JDK if they want to upgrade (maybe
because they are interested in a bug fix) won't make them very happy.

/JK

2009/6/19 Andrew Robinson <andrew.rw.robinson@gmail.com>:
> We currently force JDK 5 in the maven build because we were having
> problems with developers checking in JDK6 specific code and not
> realizing it.
>
> -Andrew
>

Mime
View raw message