myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Lessard <simon.lessar...@gmail.com>
Subject Re: MyFaces2.0 compile error in javax.faces.component._SelectItemsIterator
Date Wed, 06 May 2009 14:30:26 GMT
That's good to know. Maybe we should wikify that fact for MyFaces in
general?

~ Simon

On Wed, May 6, 2009 at 5:11 AM, Werner Punz <werner.punz@gmail.com> wrote:

> I assume the problem with Netbeans (which in my opinion currently has the
> best maven support) is that its maven implementation to my knowledge
> is rather old. So things which work on Maven 2.0.9 or 2.0.10 do not work
> often on Netbeans which relies on a way older maven implementation.
>
> Not sure if you can replace the integrated netbeans maven with
> an external one.
>
>
> Things probably will become better once Netbeans 6.7 is out
>
> Werner
>
>
> Matthias Wessendorf schrieb:
>
>  On Wed, May 6, 2009 at 9:03 AM, Ganesh <ganesh@j4fry.org> wrote:
>>
>>> Hi Simon,
>>>
>>> It's the Netbeans IDE's maven plugin that doesn't recognize the generated
>>> classes path and thus shows compile errors. I've switched to Eclipse
>>> (needed
>>> to add the maven plugin and enable dependency management and nested
>>> modules)
>>> and things work fine :-)
>>>
>>
>> real man's IDE ;-)
>> Funny that it does not work in Netbeans. The IDEs I am using (JDEV and
>> Eclipse) understand
>> those generated artifcats. Tools just should work, eh ? :)
>>
>>  Best Regards,
>>> Ganesh
>>>
>>> Simon Lessard schrieb:
>>>
>>>> Hi,
>>>>
>>>> The class gets generated by a Maven plugin using _UISelectItems as a
>>>> base.
>>>> It works fine for me. Did you checkout also the mavin plugin projects?
>>>>
>>>>
>>>> Regards,
>>>>
>>>> ~ Simon
>>>>
>>>> On Sun, Apr 19, 2009 at 4:30 PM, Ganesh <ganesh@j4fry.org
>>>> <mailto:ganesh@j4fry.org>> wrote:
>>>>
>>>>   Hi Simon,
>>>>
>>>>   I have run mvn install. In the API
>>>>   javax.faces.component._SelectItemsIterator contains references to
>>>>   class UISelectItems which doesn't exists. There is a class named
>>>>   javax.faces.component._UISelectItems and if you wouldn't say it
>>>>   compiles fine for you I'd think it's a typo in
>>>>   javax.faces.component._SelectItemsIterator. Similar issues exist
>>>>   for UIMessage and UIMessages.
>>>>
>>>>   Here's a link to the ViewVC of the 2_0_0 branch. I think it
>>>>   supports that there is _UISelectItems, but no UISelectItems and
>>>>   that _SelectItemsIterator references UISelectItems:
>>>>
>>>>
>>>>
>>>> http://svn.apache.org/viewvc/myfaces/core/branches/2_0_0/api/src/main/java/javax/faces/component/
>>>>
>>>>   Can you please check this again?
>>>>
>>>>   Best Regards,
>>>>   Ganesh
>>>>
>>>>   Simon Lessard schrieb:
>>>>
>>>>       Hi Ganesh,
>>>>
>>>>       I think you forgot to execute mvn install on the build maybe
>>>>       because it compiles fine for me.
>>>>
>>>>       As for running the whole thing I don't think it would be
>>>>       working yet since some Lifecycle phases were already modified
>>>>       to use the new Ajax API on partial request, but there's no
>>>>       impl for that code yet. Once the partial context and writer as
>>>>       well as JSP VDL are implemented then I think a simpel test
>>>>       case will be runnable.
>>>>
>>>>
>>>>       Regards,
>>>>
>>>>       ~ Simon
>>>>
>>>>
>>>>
>>
>>
>>
>

Mime
View raw message