myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: EnumConverter in commons 1.1 branch
Date Wed, 02 Jul 2008 09:35:47 GMT
On Wed, Jul 2, 2008 at 10:19 AM, simon.kitching@chello.at
<simon.kitching@chello.at> wrote:
> Volker Weber schrieb:
>>
>> Hi,
>>
>> Leonardo has just deleted the EnumConverter from the jsf1.1 branch of
>> commons.
>> This converter was the reason for me to use a snapshot version in our
>> production application.
>>
>> Is it really necessary  to have the commons jsf1.1 branch java 1.4
>> compatible?
>> I know jsf1.1 is, but commons is an extension, so why should we
>> restrict commons?
>>
>> We may provide a retroweaved (if this is possible with this Converter)
>> release for 1.4 users, as we do for tobago.
>>
>
> I think we really *should* have commons-1.1 compatible with java1.4.

I think that this is not necessary. Trinidad 1.0.x (which is the JSF
1.1 version)
supports only Java5.

>
> Setting up retroweaver, etc. is a pain in the butt. So if *you* (Volker) can
> provide a clean and simple patch to get this working, fine. But otherwise
> I'm happy with removing EnumConverter from commons1.1.

just because of JSF 1.1 uses outdated Java version?

-M

-- 
Matthias Wessendorf

further stuff:
blog: http://matthiaswessendorf.wordpress.com/
sessions: http://www.slideshare.net/mwessendorf
mail: matzew-at-apache-dot-org

Mime
View raw message