myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Niklas <daniel.nik...@continentale.de>
Subject [trinidad] wrong markup for navigationPane?!
Date Fri, 18 Apr 2008 14:50:10 GMT

Hi,

i think, that there is a problem with the markup rendered for navigationPane
(hint="bar"). The component is embedded in one <div>. A <table> is rendered
for each child - commandNavigationItems. These <table>s are containing a
<tbody> with "style="display:inline". This causes strange behaviour and i
think this is not correct.

Have a look at the 
http://www.irian.at/trinidad-demo/faces/components/navigationPane.jspx
component-demo  and inspect the bar-items with firebug. You'll see, that
firebug shows the component somewhere else it is renderd. Firebug works fine
with display:table-header-group. I think, this is the default-value here,
but i'am not sure.

Is there a way for a workaround here?

Best regards
Daniel

P.S.:
Example for a navigationPane with two items. I've deleted all styling and
class-attributes.

<div>

<table cellspacing="0" cellpadding="0" border="0" style="display: inline;">
	<tbody style="display:table-header-group;">
	<tr>
		<td style="">
			<div> # item one </div>
		</td>
		<td>
			<div>|</div>
		</td>
	</tr>
	</tbody>
</table>

<table cellspacing="0" cellpadding="0" border="0" style="display: inline;">
	<tbody style="display:table-header-group;">
	<tr>
		<td style="">
			<div> # item two </div>
		</td>
		<td>
			<div>|</div>
		</td>
	</tr>
	</tbody>
</table>

</div>

-- 
View this message in context: http://www.nabble.com/-trinidad--wrong-markup-for-navigationPane-%21-tp16763468p16763468.html
Sent from the My Faces - Dev mailing list archive at Nabble.com.


Mime
View raw message