myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luca Stancapiano (JIRA)" <...@myfaces.apache.org>
Subject [jira] Created: (MYFACES-1832) bad charset encoding on <f:param> tag
Date Sat, 08 Mar 2008 13:35:46 GMT
bad charset encoding on <f:param> tag
-------------------------------------

                 Key: MYFACES-1832
                 URL: https://issues.apache.org/jira/browse/MYFACES-1832
             Project: MyFaces Core
          Issue Type: Bug
          Components: General
    Affects Versions: 1.2.2,  1.2.0, 1.1.5
         Environment: myfaces 1.1.5 
            Reporter: Luca Stancapiano
             Fix For:  1.1.6-SNAPSHOT, 1.1.6


there is a bug into myfaces 1.1.5 and up..... 

on a page as it:

<h:form>                                                                           

                 <h:commandLink action="#{Action.execute}">
                    <h:outputText value="some"/>
                    <f:param name="id" value="#{instance.id}"/>
                 </h:commandLink>
</h:form> 

using <f:param name="id" value="#{instance.id}"> tag inside <h:commandLink> ,
I see that instance.id value has a bad encoding... if I use a word with special characters
as à, è, ù, ì as instance.id for example 'modalità' , it is encoded into 'modalit&amp;#224'
instead of 'modalit&agrave' . When I click on link through command link, that id cannot
to be decoded and so cannot to work with the real value ofinstance.id

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message