myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Freedman <michael.freed...@oracle.com>
Subject Re: [jira] Assigned: (PORTLETBRIDGE-19) PortletExternalContextImpl.encodeResourceURL seems to return prepend the context path twice
Date Thu, 10 Jan 2008 21:24:08 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Thanks.  But why don't we use this one as the exercise we do together
next week so I can learn how the process works?<br>
     -Mike-<br>
<br>
Scott O'Bryan (JIRA) wrote:
<blockquote cite="mid15736280.1199999074153.JavaMail.jira@brutus"
 type="cite">
  <pre wrap="">     [ <a class="moz-txt-link-freetext" href="https://issues.apache.org/jira/browse/PORTLETBRIDGE-19?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel">https://issues.apache.org/jira/browse/PORTLETBRIDGE-19?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel</a>
]

Scott O'Bryan reassigned PORTLETBRIDGE-19:
------------------------------------------

    Assignee: Michael Freedman  (was: Scott O'Bryan)

Hey Mike, I can help you commit this if you need any help...

  </pre>
  <blockquote type="cite">
    <pre wrap="">PortletExternalContextImpl.encodeResourceURL seems to return prepend
the context path twice
-------------------------------------------------------------------------------------------

                Key: PORTLETBRIDGE-19
                URL: <a class="moz-txt-link-freetext" href="https://issues.apache.org/jira/browse/PORTLETBRIDGE-19">https://issues.apache.org/jira/browse/PORTLETBRIDGE-19</a>
            Project: MyFaces Portlet Bridge
         Issue Type: Bug
         Components: Impl
   Affects Versions: 1.0.0-SNAPSHOT
        Environment: exo-enterprise-webos-r21645 (includes Tomcat 6.0.10), JSF RI 1.2_05 and
Windows XP 
           Reporter: Kito D. Mann
           Assignee: Michael Freedman
            Fix For: 1.0.0-SNAPSHOT

        Attachments: guessnumberportlet-301.war, jira_19.patch, jira_19b.patch


I've been experimenting with several portlet bridges with the standard guessnumber app. The
following JSF tag declaration:
&lt;h:graphicImage id="waveImg" url="/wave.med.gif" /&gt;
Generates this URL with the portlet bridge:
&lt;img id="I26380823I:j_id_jsp_1712459602_0:helloForm:waveImg" src="/guessnumberportlet-301/guessnumberportlet-301/wave.med.gif"
/&gt;
In this application, the web app _and_ the portlet have the same name "guessnumberportled-301".
I've tested eXo with he MyFaces and Apache Portals bridges, and neither of them have this
problem, so I think this may be a problem with this particular bridge. 
Everything works fine with if you remove the first slash:
&lt;h:graphicImage id="waveImg" url="wave.med.gif" /&gt;
This generates the expected outcome:
&lt;img id="I26380823I:j_id_jsp_1712459602_0:helloForm:waveImg" src="/guessnumberportlet-301/wave.med.gif"
/&gt;
I haven't had a chance to actually step through the bridge's code or try this in Pluto.
    </pre>
  </blockquote>
  <pre wrap=""><!---->
  </pre>
</blockquote>
</body>
</html>

Mime
View raw message