myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Kurz (JIRA)" <...@myfaces.apache.org>
Subject [jira] Created: (MYFACES-1746) Properties not set in UIComponentTag.createComponent()
Date Wed, 17 Oct 2007 17:27:50 GMT
Properties not set in UIComponentTag.createComponent()
------------------------------------------------------

                 Key: MYFACES-1746
                 URL: https://issues.apache.org/jira/browse/MYFACES-1746
             Project: MyFaces Core
          Issue Type: Bug
    Affects Versions: 1.2.1-SNAPSHOT
            Reporter: Michael Kurz
             Fix For: 1.2.1-SNAPSHOT
         Attachments: myfaces-api-1746.patch

I ran into a problem with MyFaces 1.2.1-SNAPSHOT and Tomahawk 1.1.6. The problem was that
for <t:commandButton id="cancel" value="Cancel" action="#{aBean.cancel}" /> no value
was rendered and that the action was not working. With 1.2.0 it worked.

After some debugging I found out that setProperties() is not called in UICompnentTag.createComponent().
In 1.2.0 setProperties was called in UIComponentClassicTagBase.findComponent().

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message