myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Lessard" <simon.lessar...@gmail.com>
Subject Re: [Trinidad] browser build-in autocomplete box (IE 7 issue...)
Date Wed, 12 Sep 2007 15:47:02 GMT
Also, but not directly linked to this, autoSubmit is no longer triggered
from selection from the autocomplete list with FF 2.x while it was in FF 1.x


Regards,

~ Simon

On 9/12/07, Mario Ivankovits <mario@ops.co.at> wrote:
>
> Hi!
> > I noticed that this doesn't show up in IE7, but in FF2 it does.
> > (no Trinidad isn't rendering something like autocomplete="off")
> >
> Christian Swoboda already posted about a bug in IE
>
> His text:
> >
> > Hi!
> >
> > We are developing a new application with myfaces 1.1.5 and discovered
> > that there's a problem with Internet Explorer's autocomplete
> > (Intelliforms)
> > feature. The text input fields do not "remember" their values, i. e.
> > Autocomplete does not work.
> >
> > I found the following MS support article
> > http://support.microsoft.com/kb/329156/en-us
> > which declares that there's an Internet Explorer Bug ;-) when using
> > scripts to submit forms.
> >
> > They offered the following "workaround":
> > ---
> > function subForm()
> > {
> > window.external.AutoCompleteSaveForm(f1);
> > f1.submit();
> > }
> > ---
> >
> > Could/should this be added to oamSubmitForm() ?
> > If yes, how?
>
> But you already told me that you've experience the same with plain HTML
> .... so might be another problem.
>
>
> Ciao,
> Mario
>
>

Mime
View raw message