myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Lessard" <simon.lessar...@gmail.com>
Subject Re: JSF 1.2 API backward compatible?
Date Wed, 05 Sep 2007 13:31:47 GMT
Hello Mario,

It's the opposite, as for any backward compatible system. It means that you
can, theoretically,  run a JSF 1.1 application on a 1.2 system. However, if
you did not use any 1.2 specific API, meaning you developed no new
component, because otherwise you would be using unified EL, thus JSF
1.2API, I guess the application should run on a JSF
1.1 server.


Regards,

~ Simon

On 9/5/07, Mario Ivankovits <mario@ops.co.at> wrote:
>
> Hi!
>
> Is the JSF 1.2 API backward compatible?
>
> An application developed with the JSF 1.2 API should run on 1.1 as long
> as no 1.2 specific stuff will be used, no?
>
> I ask as I had a UOE in orchestra which seems happened after I override
> the ApplicationFactory (and the Application) but still use JSF 1.1.
> For now I changed to a proxy based solution, but it can't be that I now
> have to proxy every delegation, can it?
>
> Ciao,
> Mario
>
>

Mime
View raw message