myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Winer (JIRA)" <...@myfaces.apache.org>
Subject [jira] Resolved: (TRINIDAD-647) Client-side validation doesn't work
Date Sat, 25 Aug 2007 01:07:30 GMT

     [ https://issues.apache.org/jira/browse/TRINIDAD-647?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Adam Winer resolved TRINIDAD-647.
---------------------------------

       Resolution: Fixed
    Fix Version/s: 1.0.3-core
         Assignee: Adam Winer

I've actually already fixed this in 1.0.3.  FYI, the bug was in
_validateAlert;  it only returns without showing an alert if:

  if (failureMap.length == 0)
    return true;

... but failureMap isn't an array - it's a map.  So this
test doesn't work (it's undefined == 0, which is false).
    


> Client-side validation doesn't work
> -----------------------------------
>
>                 Key: TRINIDAD-647
>                 URL: https://issues.apache.org/jira/browse/TRINIDAD-647
>             Project: MyFaces Trinidad
>          Issue Type: Bug
>    Affects Versions: 1.0.2-core
>            Reporter: Tomas Havelka
>            Assignee: Adam Winer
>             Fix For: 1.0.3-core
>
>
> When client-validation is set to ALERT in trinidad-config.xml validation error occurs
on each submit, even if the form data are filled correctly. For example for any input filed
(select, etc.) which value is required and filled, validation error alert appears with message
that validation error occurs, but with no component validation error message.
> This is new side effect of any changes made to version 1.0.2, because in version 1.0.1
this works fine.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message