myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Danny Robinson" <dannyjrobin...@gmail.com>
Subject Re: [Trinidad] tabIndex - adding my vote for this feature
Date Fri, 04 May 2007 20:02:21 GMT
no preference on the naming convention, but you're right 'all components'
may be an overkill.

On 5/4/07, Adam Winer <awiner@gmail.com> wrote:
>
> I'm +0...  never liked the HTML attribute much, but there's
> demand for it...  Two design questions before going forward:
>
>   - Should it be tabindex or tabIndex?
>     Trinidad generally uses camel-case.  I prefer tabIndex.
>
>   - Should the attribute be on components that ordinarily do not
>     have navigation?
>     Danny says "all components".  You could, in theory, put tabindex
>     on a ordinary span in HTML, so we could add it to outputText,
>     etc...  However, I'd rather not - it's extra overhead for a rarely
>     used feature, and unused attributes *are* a performance problem,
>     especially for outputText and panel components.
>
> -- Adam
>
>
> On 5/4/07, Danny Robinson <dannyjrobinson@gmail.com> wrote:
> > I noted Eric created issue ADFFACES-482 to have tabindex added to all
> > components.  I know this has come up before and general comments were
> around
> > its limitations, however even with its limitations (ie. no dynamic
> > calculation for subviews etc.) I still feel it would be better to have
> this
> > attribute than the complete lack of support for any navigation ordering
> that
> > Trinidad has currently.
> >
> > +1 (non-binding)
> >
> > --
> > Chordiant Software Inc.
> > www.chordiant.com
>



-- 
Chordiant Software Inc.
www.chordiant.com

Mime
View raw message