myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Spencer <pau...@apache.org>
Subject Re: Checksum error on JSF RI artifacts on continuum server.
Date Fri, 01 Jun 2007 03:05:35 GMT
Wendy,
When I build Tomahawk locally, I do not see the errors.  In addition I
do not have javax.servlet.jsp:jsp-api:jar:1.2.0 in my local repository.

I am wondering if the RI artifacts are corrupt/outdated for some strange
reason.

Based on the following, it appears the artifacts should not be used. Thus
leading be to believe the RI artifacts on the continuum server are bad.

mvn help:effective-pom displays the following.

     <dependency>
       <groupId>javax.faces</groupId>
       <artifactId>jsf-impl</artifactId>
       <version>1.1_02</version>
       <scope>test</scope>
       <exclusions>
         <exclusion>
           <artifactId>jsp-api</artifactId>
           <groupId>java.servlet.servlet.jsp</groupId>
         </exclusion>
         <exclusion>
           <artifactId>servlet-api</artifactId>
           <groupId>javax.servlet</groupId>
         </exclusion>
         <exclusion>
           <artifactId>jsp-api</artifactId>
           <groupId>javax.servlet.jsp</groupId>
         </exclusion>
         <exclusion>
           <artifactId>jstl</artifactId>
           <groupId>javax.servlet.jsp.jstl</groupId>
         </exclusion>
       </exclusions>
     </dependency>

Paul Spencer

Wendy Smoak wrote:
> On 5/31/07, Paul Spencer <paulsp@apache.org> wrote:
> 
>> I am trying to add a build of Tomahawk against the RI, but there are 
>> Checksum errors
>> on JSF RI artifacts on continuum server see[1].
>>
>> What is the best way to resolve this?  I believe the goal 
>> dependency:purge-local-repository
>> will remove the artifacts, but it seems extreme since it will remove 
>> ALL dependencies.
> 
> 
> It looks to me like the build failure is due to a missing dependency,
> not bad checksums.  Those are just warnings and are ignored.
> 
> Or are you saying that javax.servlet.jsp:jsp-api:jar:1.2.0 is
> available in a public repo and Maven is refusing to download it?
> 


Mime
View raw message