myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Beyer ...@thomas-daily.de>
Subject Re: build problem
Date Mon, 04 Dec 2006 16:36:14 GMT

Am 01.12.2006 um 14:16 schrieb Wendy Smoak:

>> So I just downloaded and installed subclipse, maven, maven plugin for
>> eclipse, etc.
>>
>> Then I checked out tomahawk.
>
> What URL?

<https://svn.apache.org/repos/asf/myfaces/tomahawk/trunk/core>

as I found right here:

<http://myfaces.apache.org/tomahawk/source-repository.html>

>> When I tried to build the project using the provided pom.xml, I get
>> an error message.
> ...
>> org.apache.maven.project.ProjectBuildingException: Cannot find
>> parent: org.apache.myfaces.tomahawk:tomahawk-project for project:
>> org.apache.myfaces.tomahawk:tomahawk:jar:null
>
> It sounds like you've checked out just tomahawk/trunk/core instead of
> the entire trunk.

hmm, so I guess the given URL on the page I mentioned above is wrong.

>   The next problem you're likely to run into is that
> Tomahawk and MyFaces core both use the 'shared' module.
>
> The easiest thing to do is check out the 'current' svn external
> definition, which is described here:
> http://wiki.apache.org/myfaces/Building_With_Maven

ah, so I take

<https://svn.apache.org/repos/asf/myfaces/current>

great.

Using the "Maven 2.x Plug-in for Eclipse" I get "BUILD SUCCESSFUL"
but I don't see any target folders (with goal "install").

Then I tried command line (mvn install) and that works!

thank you!

Does someone use Maven 2 with Eclipse and has an idea
what is going wrong? "Run As" -> "Maven2 build..." doesn't work well ...

cheers
Marcus


Mime
View raw message