myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alexeinov <alexei.novi...@combitech.se>
Subject RE: JScookMenu is not rendered with Facelets
Date Thu, 21 Sep 2006 08:51:35 GMT



Tom Innes wrote:
> 
> 
> There is a bug however if you try to override the Stylesheet.
> 
> 

Thanks for reply, Tom. My problem is that the menu is not rendered at all.
The following line of HTML is all that I get in the rendered page:
<!-- Start: javax.faces.Command["_id0"] --><input id="_id0" name="_id0"
type="submit" value="">

I never come to the point where the stylesheet could be a problem. Anyway, I
applied the fix suggested in
https://issues.apache.org/jira/browse/TOMAHAWK-575 but it does not change
anything.

I tried MyFaces and Tomahawk both 1.1.3 and 1.1.5 snapshot - same result.

There must be something special about Facelets and JSCookMenu that I'm
missing. The tag is described in /WEB-INF/tomahawk.taglib.xml as

    <tag>
        <tag-name>jscookMenu</tag-name>
        <component>
            <component-type>org.apache.myfaces.JSCookMenu</component-type>
        </component>
    </tag>

faces-config definse JSCookMenu as
<component>
<component-type>org.apache.myfaces.JSCookMenu</component-type>
<component-class>org.apache.myfaces.custom.navmenu.jscookmenu.HtmlCommandJSCookMenu</component-class>
</component>

Still something is wrong
-- 
View this message in context: http://www.nabble.com/JScookMenu-is-not-rendered-with-Facelets-tf2303975.html#a6423955
Sent from the My Faces - Dev mailing list archive at Nabble.com.


Mime
View raw message