myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Voss (JIRA)" <>
Subject [jira] Created: (TOMAHAWK-580) panelNavigation2 JavaScript problem
Date Thu, 03 Aug 2006 11:40:14 GMT
panelNavigation2 JavaScript problem

                 Key: TOMAHAWK-580
             Project: MyFaces Tomahawk
          Issue Type: Bug
          Components: Panel Navigation2
    Affects Versions: 1.1.5-SNAPSHOT
         Environment: Windows XP, Tomcat, Eclipse, MyFaces 1.1.3
            Reporter: Alexander Voss


I've tried to upgrade to 1.1.5-SNAPSHOT (as of 3rd August 2006) to test the fix for TOMAHAWK-565
but run into a problem with the JavaScript for panelNavigation2. In Firefox, I get 

> Error: document.forms.navpanelForm.elements['navpanelForm:_idcl'] has no properties
> Source File: https://localhost:8443/ntrac_recruit/home.jsf?_flowId=home-flow
> Line: 1

IE shows an equivalent error. The source for the navigation looks like this:

<div id="navpanel">
        <h:form id="navpanelForm">
          <input type="hidden" name="_flowExecutionKey" value="#{requestScope.flowExecutionKey}"/>
          <t:panelNavigation2 id="menu" layout="list">
            <t:commandNavigation2 value="home" action="toHomeFlow">
              <img src="/ntrac_recruit/images/home.png"/> Home </t:commandNavigation2>
            <t:commandNavigation2 value="Search" action="toSearchFlow" visibleOnUserRole="ROLE_USER">
              <img src="/ntrac_recruit/images/search.png"/> Search </t:commandNavigation2>
            <t:commandNavigation2 value="Recruit" action="toRecruitFlow" visibleOnUserRole="ROLE_NURSE">
              <img src="/ntrac_recruit/images/recruit.png"/> Recruit </t:commandNavigation2>
            <t:commandNavigation2 value="Stats" action="toStatsFlow">
              <img src="/ntrac_recruit/images/stats.png"/> Statistics </t:commandNavigation2>
            <t:commandNavigation2 value="SCAN Linkage" action="toSCANLinkageFlow" visibleOnUserRole="ROLE_SCAN">
              <img src="/ntrac_recruit/images/linkage.png"/> SCAN Linkage </t:commandNavigation2>
            <t:commandNavigation2 value="ISD Linkage" action="toISDLinkageFlow" visibleOnUserRole="ROLE_ISD">
              <img src="/ntrac_recruit/images/linkage.png"/> ISD Linkage </t:commandNavigation2>
            <t:commandNavigation2 value="Backup" action="toBackup" visibleOnUserRole="ROLE_ADMIN">
              <img src="/ntrac_recruit/images/backup.png"/>  Backup </t:commandNavigation2>

This worked fine with Tomahawk 1.1.3. A similar issue has been described here:

Cheers, Alex

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message