myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruno Marti (JIRA)" <...@myfaces.apache.org>
Subject [jira] Commented: (TOMAHAWK-571) inputSuggestAjax not correctly rendered in IE
Date Mon, 07 Aug 2006 06:19:14 GMT
    [ http://issues.apache.org/jira/browse/TOMAHAWK-571?page=comments#action_12426140 ] 
            
Bruno Marti commented on TOMAHAWK-571:
--------------------------------------

sorry for being late -> holidays

I've tried both ways to set a width for the input field:
style="width:50px;color:red;"
or
styleClass="myStyle" // with the same style def. insight a css

but neither nor is working.
If I look at the html source the above pass-through attributes are not set.
However the size attribute is passed through but doesn't affect the size.



> inputSuggestAjax not correctly rendered in IE
> ---------------------------------------------
>
>                 Key: TOMAHAWK-571
>                 URL: http://issues.apache.org/jira/browse/TOMAHAWK-571
>             Project: MyFaces Tomahawk
>          Issue Type: Bug
>          Components: InputSuggestAjax
>    Affects Versions: 1.1.4-SNAPSHOT, 1.1.5-SNAPSHOT
>         Environment: Windows XP SP2, Tomcat 5.5.16, 
> IE 6.0.2900.2180.xpsp_sp2_gdr.050301-1519, Firefox 1.5.0.4
> JARs: myfaces-api-1.1.5-SNAPSHOT.jar, myfaces-impl-1.1.5-SNAPSHOT.jar, tomahawk-1.1.5-SNAPSHOT.jar,
tomahawk-sandbox-1.1.5-SNAPSHOT.jar
>            Reporter: Bruno Marti
>         Attachments: inputsuggestajaxFirefox.jpg, inputsuggestajaxIE.jpg
>
>
> IE: The inputSuggestAjax Element is always displayed in a size of 0, even if the size="100"
attribute is set.
> Userinputs aren't possible.
> Firefox: works fine
> code:
> <h:panelGrid columns="2" id="myfaces_ajaxPanel">
> 	<h:outputText value="Enter a value: " />
> 	<s:inputSuggestAjax suggestedItemsMethod="#{myCountryBean.getCountries}" 
> 		required="true" maxSuggestedItems="10"	id="inputSuggest1" size="100"
> 		value="#{mySelectedCountryRecord.selectedCountry}" />
> </h:panelGrid>
> Tested with nightly build of 1.1.5 from 27. July 2006 or also existing in tomahawk-sandbox-examples-1.1.4-SNAPSHOT.war
> Is there a render problem or have I misconfigured something?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message