myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: [OT] javax.mail (1.4) dependency
Date Tue, 25 Jul 2006 06:53:41 GMT
:) yes, I know (was involved in some of the jakarat email stuff).

but...

<snip>
JavaMail API 1.4 Release
The JavaMail 1.4 release includes many API improvements approved by
the Java Community Process via JSR-919. It also includes improvements
in MIME parsing performance and support for parsing and constructing
Delivery Status Notifications. Note: You will also need the JavaBeans
Activation Framework (JAF) extension that provides the
javax.activation package. We suggest you use version 1.1 of JAF, the
latest release.
</snip>

<quote>We suggest you use version 1.1 of JAF</quote>

Makes no sense to me, when they ship their pom with 1.0.3 dependency.

That was my point ;)

On 7/24/06, Mario Ivankovits <mario@ops.co.at> wrote:
> Hi Matthias!
> > But... why has the javax.mail 1.4 jar a dependency to activation 1.0.3 ?
> Its simply a requirement http://java.sun.com/products/javamail/
>
> I already tried to use it without activation bad that wont work.
> As far as I remember they use it to instanciate the various provider
> (pop, imap, etc) through activation
>
> Ciao,
> Mario
>
>


-- 
Matthias Wessendorf

further stuff:
blog: http://jroller.com/page/mwessendorf
mail: mwessendorf-at-gmail-dot-com

Mime
View raw message