myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "RD (JIRA)" <...@myfaces.apache.org>
Subject [jira] Commented: (TOMAHAWK-514) Method not triggered by s:valueChangeNotifier
Date Wed, 05 Jul 2006 10:19:30 GMT
    [ http://issues.apache.org/jira/browse/TOMAHAWK-514?page=comments#action_12419246 ] 

RD commented on TOMAHAWK-514:
-----------------------------

I have tried to do that yesterday, but as soon as I've set breakpoints on the two methods,
Eclipse (or jboss, I don't know) has begun to operate in a strange manner.

I get the following error messages, whether I use breakpoints or not:

12:10:52,468 ERROR [[Faces Servlet]] Servlet.service() for servlet Faces Servlet threw exception
java.lang.NullPointerException
	at org.apache.myfaces.custom.updateactionlistener.UpdateActionListener.processAction(UpdateActionListener.java:134)
	at javax.faces.event.ActionEvent.processListener(ActionEvent.java:48)
	at javax.faces.component.UIComponentBase.broadcast(UIComponentBase.java:484)
	at javax.faces.component.UICommand.broadcast(UICommand.java:75)
	at org.apache.myfaces.custom.navmenu.htmlnavmenu.HtmlCommandNavigationItem.broadcast(HtmlCommandNavigationItem.java:302)
	at javax.faces.component.UIViewRoot._broadcastForPhase(UIViewRoot.java:94)
	at javax.faces.component.UIViewRoot.processDecodes(UIViewRoot.java:136)
	at org.apache.myfaces.lifecycle.LifecycleImpl.applyRequestValues(LifecycleImpl.java:219)
	at org.apache.myfaces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:71)
	at javax.faces.webapp.FacesServlet.service(FacesServlet.java:137)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at org.apache.myfaces.webapp.filter.ExtensionsFilter.doFilter(ExtensionsFilter.java:144)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
	at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:175)
	at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:74)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
	at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
	at java.lang.Thread.run(Thread.java:595)

It seems that my application doesn't run at all.

> Method not triggered by s:valueChangeNotifier
> ---------------------------------------------
>
>          Key: TOMAHAWK-514
>          URL: http://issues.apache.org/jira/browse/TOMAHAWK-514
>      Project: MyFaces Tomahawk
>         Type: Bug

>     Versions: 1.1.5-SNAPSHOT
>  Environment: JBoss 4.0.4.GA
> MyFaces 1.1.3
> Tomahawk+Sandbox 1.1.5 snapshot
>     Reporter: RD

>
> This is a snippet from my JSF page:
> 		<h:selectOneMenu id="vertragid" required="true"
> 		value="#{rufnummerEditBean.vertragid}"
> 		disabled="#{!(rufnummerEditBean.editable)}"
> 		onchange="submit()" immediate="true">
> 			<s:valueChangeNotifier method="#{rufnummerEditBean.changeVertragid}"/>
> 			<f:selectItems value="#{rufnummerEditBean.vertragidList}"/>
> 		</h:selectOneMenu>
> This is the associated piece of code:
> 	public void changeVertragid(ValueChangeEvent event) {
> 		Integer newval=(Integer)(event.getNewValue());
> 		if(debugInfo) System.out.println("changeVertragid "+newval);
> 		setVertragid(newval);
> 		List<SelectItem> listTarifs=getTarifidList();
> 		if(listTarifs.isEmpty()) setTarifid2(null);
> 		else setTarifid2((Integer)(listTarifs.get(0).getValue()));
> 	}
> When selecting some value in the combo box Vertragid, the method changeVertragid is not
called (or else I would have seen the output of System.out.println in the log).
> I have also tried with immediate="false", but there is no difference.
> What should I do to fix this?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message