myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Ray (JIRA)" <...@myfaces.apache.org>
Subject [jira] Commented: (TOMAHAWK-505) Unable to work around DummyForm issue
Date Wed, 12 Jul 2006 04:06:30 GMT
    [ http://issues.apache.org/jira/browse/TOMAHAWK-505?page=comments#action_12420495 ] 

Daniel Ray commented on TOMAHAWK-505:
-------------------------------------

Finally got around to solving this issue. The problem also falls back to JBoss and not MyFaces.
JBoss 4.0.4 contains an older version of MyFaces in the directory <JBOSS_HOME>\server\default\deploy\jbossweb-tomcat55.sar\jsf-libs.
I removed this directory, set the classloading params of the jboss-service.xml file back to
true and now all is well i.e. MyFaces 1.1.5 and Log4J are working correctly.

> Unable to work around DummyForm issue
> -------------------------------------
>
>          Key: TOMAHAWK-505
>          URL: http://issues.apache.org/jira/browse/TOMAHAWK-505
>      Project: MyFaces Tomahawk
>         Type: Bug

>   Components: Extended CommandLink/CommandButton
>     Versions: 1.1.3
>     Reporter: Daniel Ray
>     Priority: Blocker

>
> Getting the following error
> java.lang.NoSuchMethodError: org.apache.myfaces.renderkit.html.util.DummyFormUtils.isWriteDummyForm(Ljavax/faces/context/FacesContext;)Z
> I've tried the recommended work around from issue 416 to no avail. I've tried using the
1.1.4 and 1.1.5 core and 1.1.4 Tomahawk jars without much success either. So, to help clear
things up with the changes that have taken place since the 1.1.2 release, what is it that
I need to do to get things running again. The 1.1.4 examples are broken for me as well, so
I can't derive the solution from there.
> 1. Changes to faces-config (component/render tags)
> 2. Jars to use.
> This is a show stopper for me. Many thanks for your clarification.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message