myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Schofield" <sean.schofi...@gmail.com>
Subject Re: JSF 1.2 [was: Cancelled: JavaOne MyFaces Committers/Contributors meeting]
Date Wed, 24 May 2006 16:56:47 GMT
OK so Stan is past the TC 5.5 point.  Why do we need two branches?
Can't we just say that 1.2 depends on TC 6.0 or Glassfish?  I still
think we need to do everything we can to avoid multiple branches.

Sean

On 5/24/06, Martin Marinschek <martin.marinschek@gmail.com> wrote:
> No. The current build should be compatible again - if I don't have old
> information here...
>
> regards,
>
> Martin
>
> On 5/24/06, Sean Schofield <sean.schofield@gmail.com> wrote:
> > So does this mean that our Tomahawk releases are no longer compatible
> > with the RI?  That's our current problem right?
> >
> > Sean
> >
> > On 5/24/06, Martin Marinschek <martin.marinschek@gmail.com> wrote:
> > > There is no 1.1 compliant way of fixing dummyform - there just isn't.
> > >
> > > I would have gone with a single branch for 1.2 and checking in TC5.5
> > > compatible stuff only, but Stan has already worked on 1.2, and he has
> > > implemented also TC6 depending things, so no chance to go with this,
> > > except we want to loose what Stan did, and I wouldn't.
> > >
> > > I want to do development on the 1.1 branch for bugfixes only anymore.
> > > 1.2 is our future, and we should go there!
> > >
> > > regards,
> > >
> > > Martin
> > >
> > > On 5/23/06, Sean Schofield <sean.schofield@gmail.com> wrote:
> > > > Are we talking about the fix for DummyForm?  Are we not going to
> > > > attempt to have a 1.1 compatible fix?  What about a single branch for
> > > > 1.2 and only check in the Tomcat 5.5 compatible stuff?
> > > >
> > > > I agree with Craig that you don't want to be actively developing on
> > > > the trunk plus two branches.  Trust me, its difficult enough managing
> > > > this when we have a short-lived branch for a release.
> > > >
> > > > -1 for a long-term double branch strategy.
> > > >
> > > > Sean
> > > >
> > > > On 5/23/06, Martin Marinschek <martin.marinschek@gmail.com> wrote:
> > > > > It's just that we need the 1.2 features for several things we want
to
> > > > > fix right now - and TC6 is still not released, so we can't work with
> > > > > the full feature set of 1.2.
> > > > >
> > > > > regards,
> > > > >
> > > > > Martin
> > > > >
> > > > > On 5/22/06, Sean Schofield <sean.schofield@gmail.com> wrote:
> > > > > > Why is there a need to have a separate branch for TC6 vs. TC55.
 Sorry
> > > > > > if I missed the discussion on the need for this ...
> > > > > >
> > > > > > Sean
> > > > > >
> > > > > > On 5/22/06, Martin Marinschek <martin.marinschek@gmail.com>
wrote:
> > > > > > > Hi Craig,
> > > > > > >
> > > > > > > critical fixes to 1.1. -> 1.1 branch
> > > > > > >
> > > > > > > major development --> trunk
> > > > > > >
> > > > > > > special things for 1.2 under TC6 only --> 1.2 branch
> > > > > > >
> > > > > > > With this, it should be albe to merge down the 1.2 branch
to the trunk, right?
> > > > > > >
> > > > > > > regards,
> > > > > > >
> > > > > > > Martin
> > > > > > >
> > > > > > > On 5/22/06, Craig McClanahan <craigmcc@apache.org>
wrote:
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > On 5/21/06, Martin Marinschek <martin.marinschek@gmail.com>
wrote:
> > > > > > > > > Ok,
> > > > > > > > >
> > > > > > > > > one more addition to the discussion - I'll want
to branches. One for
> > > > > > > > > JSF1.2 things which cannot be used together with
Tomcat 5.5 and, one
> > > > > > > > > for JSF1.2 things which can be used with Tomcat
5.5. I'd love trunk to
> > > > > > > > > be the JSF1.2/Tomcat 5.5 branch, and have bug
fixes for 1.1 on a real
> > > > > > > > > branch.
> > > > > > > > >
> > > > > > > > > summary:
> > > > > > > > >
> > > > > > > > > 1.1 --> branch
> > > > > > > > > 1.2 Tomcat 6 --> branch
> > > > > > > > > 1.2 Tomcat 5.5. --> trunk
> > > > > > > > >
> > > > > > > > > is that ok?
> > > > > > > >
> > > > > > > >
> > > > > > > > Wouldn't this mean that every change that worked under
5.5 would need to be
> > > > > > > > committed to both branches?  That seems like a good
way to slow down the
> > > > > > > > effort to achieve 1.2 compliance.
> > > > > > > >
> > > > > > > > > regards,
> > > > > > > > >
> > > > > > > > > Martin
> > > > > > > >
> > > > > > > >
> > > > > > > > Craig
> > > > > > > >
> > > > > > > >
> > > > > > > > > On 5/19/06, Stan Silvert < stan.silvert@jboss.com>
wrote:
> > > > > > > > > > That would be fine.  After I am done we
may need some help from Sean.
> > > > > > > > > > He was talking about putting Tomcat 6 jars
in an Apache Maven
> > > > > > > > > > repository.
> > > > > > > > > >
> > > > > > > > > > I've been building with NetBeans and not
Maven.  So someone who is more
> > > > > > > > > > Maven savvy will need to update things so
it builds correctly.  I don't
> > > > > > > > > > think it will be more complicated than adding
and removing some
> > > > > > > > > > dependencies.
> > > > > > > > > >
> > > > > > > > > > Stan Silvert
> > > > > > > > > > JBoss, Inc.
> > > > > > > > > > ssilvert@jboss.com
> > > > > > > > > > callto://stansilvert
> > > > > > > > > >
> > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > From: Manfred Geiler [mailto: manfred.geiler@gmail.com]
> > > > > > > > > > > Sent: Thursday, May 18, 2006 8:48 PM
> > > > > > > > > > > To: MyFaces Development
> > > > > > > > > > > Subject: Re: JSF 1.2 [was: Cancelled:
JavaOne MyFaces
> > > > > > > > > > > Committers/Contributors meeting]
> > > > > > > > > > >
> > > > > > > > > > > Sean,
> > > > > > > > > > > Can you please make a copy of the current
trunk to
> > > > > > > > > > > /myfaces/core/branches/jsf_1_2 ?
> > > > > > > > > > > After that, Stan can simply (?) merge
his stuff inside that.
> > > > > > > > > > > Is that ok, Stan?
> > > > > > > > > > >
> > > > > > > > > > > Manfred
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > On 5/18/06, Sean Schofield <sean.schofield@gmail.com>
wrote:
> > > > > > > > > > > > You want a 1.2 branch for core
only using the latest trunk right?  I
> > > > > > > > > > > > can create it for you if you want
...
> > > > > > > > > > > >
> > > > > > > > > > > > Sean
> > > > > > > > > > > >
> > > > > > > > > > > > On 5/18/06, Martin Marinschek
< martin.marinschek@gmail.com> wrote:
> > > > > > > > > > > > > Manfred, can you go ahead
with that 1.2 branch?
> > > > > > > > > > > > >
> > > > > > > > > > > > > regards,
> > > > > > > > > > > > >
> > > > > > > > > > > > > Martin
> > > > > > > > > > > > >
> > > > > > > > > > > > > On 5/18/06, Thomas Spiegl
<thomas.spiegl@gmail.com> wrote:
> > > > > > > > > > > > > > I'm having a look at
tomahawk 416
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > +1 for creating a 1.2
branch
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On 5/18/06, Stan Silvert
<stan.silvert@jboss.com > wrote:
> > > > > > > > > > > > > > > I have implemented
most of the new core API's and fixed most
> > > > > > > > > > of
> > > > > > > > > > > the
> > > > > > > > > > > > > > > deprecated ones
to be backwards compatible with 1.1 (if you
> > > > > > > > > > look
> > > > > > > > > > > at the
> > > > > > > > > > > > > > > 1.2 javadocs you'll
see what I mean).  If you look at the
> > > > > > > > > > section
> > > > > > > > > > > in the
> > > > > > > > > > > > > > > spec preface entitled
"What's Changed Since the Last Release"
> > > > > > > > > > you
> > > > > > > > > > > can
> > > > > > > > > > > > > > > get a feel for
what I did.  I've pretty much done everything
> > > > > > > > > > in
> > > > > > > > > > > that
> > > > > > > > > > > > > > > list.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Most of it is covered
under this issue, which just says to
> > > > > > > > > > > implement
> > > > > > > > > > > > > > > several sections
of the spec:
> > > > > > > > > > > > > > >
> > > > > > > > http://issues.apache.org/jira/browse/MYFACES-1274
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > I believe all of
1274 is complete except
> > > > > > > > > > > > > > > ApplicationImpl.getResourceBundle
().  I
> > > > > > > > needed code that reads
> > > > > > > > > > the
> > > > > > > > > > > new
> > > > > > > > > > > > > > > faces-context.xml
for that one.  However, all the ELResolver
> > > > > > > > > > stuff
> > > > > > > > > > > is
> > > > > > > > > > > > > > > done including
the ResourceBundleELResolver.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > I've also done
some of the issues listed under General
> > > > > > > > > > Changes.
> > > > > > > > > > > For
> > > > > > > > > > > > > > > each item in that
list, I created a Jira task.  You can look
> > > > > > > > > > at
> > > > > > > > > > > Jira and
> > > > > > > > > > > > > > > see which ones
I did.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > I was just getting
started on the javax.faces.webapp package
> > > > > > > > > > when
> > > > > > > > > > > I was
> > > > > > > > > > > > > > > taken off of the
project.  I probably won't commit any changes
> > > > > > > > > > > from
> > > > > > > > > > > > > > > that.  I didn't
touch the components or renderer at all.  With
> > > > > > > > > > all
> > > > > > > > > > > the
> > > > > > > > > > > > > > > backward-compatible
code I wrote, it appears that all the
> > > > > > > > > > > components
> > > > > > > > > > > > > > > still work even
though they are written the " 1.1 way".
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > So, hopefully,
what you guys will have to start with is a JSF
> > > > > > > > > > 1.2
> > > > > > > > > > > impl
> > > > > > > > > > > > > > > that is about half-way
done and still works.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Stan Silvert
> > > > > > > > > > > > > > > JBoss, Inc.
> > > > > > > > > > > > > > > ssilvert@jboss.com
> > > > > > > > > > > > > > > callto://stansilvert
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > -----Original
Message-----
> > > > > > > > > > > > > > > > From: Thomas
Spiegl [mailto:thomas.spiegl@gmail.com ]
> > > > > > > > > > > > > > > > Sent: Wednesday,
May 17, 2006 4:58 PM
> > > > > > > > > > > > > > > > To: MyFaces
Development; werpu@gmx.at
> > > > > > > > > > > > > > > > Subject: Re:
JSF 1.2 [was: Cancelled: JavaOne MyFaces
> > > > > > > > > > > > > > > > Committers/Contributors
meeting]
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > +1 for solving
tomahawk 416, being incompatible to RI is a
> > > > > > > > > > > serious
> > > > > > > > > > > > > > > issue
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Stan which
1.2 issues did you fix. Did you change any link
> > > > > > > > > > > renderers?
> > > > > > > > > > > > > > > > If not, i
am
> > > > > > > > > > > > > > > > +1 for open
a 1.2 branch
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > On 5/17/06,
Werner Punz < werpu@gmx.at> wrote:
> > > > > > > > > > > > > > > > > Sean
Schofield schrieb:
> > > > > > > > > > > > > > > > > >
I'm -1 on the 1.2 branch.  There are major issues to be
> > > > > > > > > > > fixed in
> > > > > > > > > > > > > > > the
> > > > > > > > > > > > > > > > > >
core right now.  (See TOMAHAWK-416 and related dev
> > > > > > > > > > > discussions.)
> > > > > > > > > > > > > > > I
> > > > > > > > > > > > > > > > > >
know that Stan is anxious but given the lack of interest
> > > > > > > > > > in
> > > > > > > > > > > the
> > > > > > > > > > > > > > > core
> > > > > > > > > > > > > > > > > >
trunk, its hard to imagine we have enough support to
> > > > > > > > > > sustain
> > > > > > > > > > > this
> > > > > > > > > > > > > > > > > >
branch.  Do we have firm committments from anyone else
> > > > > > > > > > > besides
> > > > > > > > > > > > > > > Stan?
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > +1 for
a fork... the reason we need to get going asap and
> > > > > > > > > > a
> > > > > > > > > > > fork
> > > > > > > > > > > > > > > helps.
> > > > > > > > > > > > > > > > > If we
wait for another bunch of issues to be fixed, this
> > > > > > > > > > will
> > > > > > > > > > > never
> > > > > > > > > > > > > > > end.
> > > > > > > > > > > > > > > > > Sorry
to say that so harsh, but the time on 1.2 is really
> > > > > > > > > > > pressing,
> > > > > > > > > > > > > > > > > given
that there wont be an option in jee to override the
> > > > > > > > > > > default
> > > > > > > > > > > > > > > JSF
> > > > > > > > > > > > > > > > > implementation
via other libs in WEB-INF/lib like it was
> > > > > > > > > > > possible in
> > > > > > > > > > > > > > > > JEE4
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > > http://www.irian.at
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Your JSF powerhouse
-
> > > > > > > > > > > > > > > > JSF Consulting,
Development and
> > > > > > > > > > > > > > > > Courses in
English and German
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Professional
Support for Apache MyFaces
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > --
> > > > > > > > > > > > > > http://www.irian.at
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Your JSF powerhouse
-
> > > > > > > > > > > > > > JSF Consulting, Development
and
> > > > > > > > > > > > > > Courses in English and
German
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Professional Support
for Apache MyFaces
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > --
> > > > > > > > > > > > >
> > > > > > > > > > > > > http://www.irian.at
> > > > > > > > > > > > >
> > > > > > > > > > > > > Your JSF powerhouse -
> > > > > > > > > > > > > JSF Consulting, Development
and
> > > > > > > > > > > > > Courses in English and German
> > > > > > > > > > > > >
> > > > > > > > > > > > > Professional Support for
Apache MyFaces
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > >
> > > > > > > > > http://www.irian.at
> > > > > > > > >
> > > > > > > > > Your JSF powerhouse -
> > > > > > > > > JSF Consulting, Development and
> > > > > > > > > Courses in English and German
> > > > > > > > >
> > > > > > > > > Professional Support for Apache MyFaces
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > >
> > > > > > > http://www.irian.at
> > > > > > >
> > > > > > > Your JSF powerhouse -
> > > > > > > JSF Consulting, Development and
> > > > > > > Courses in English and German
> > > > > > >
> > > > > > > Professional Support for Apache MyFaces
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > >
> > > > > http://www.irian.at
> > > > >
> > > > > Your JSF powerhouse -
> > > > > JSF Consulting, Development and
> > > > > Courses in English and German
> > > > >
> > > > > Professional Support for Apache MyFaces
> > > > >
> > > >
> > >
> > >
> > > --
> > >
> > > http://www.irian.at
> > >
> > > Your JSF powerhouse -
> > > JSF Consulting, Development and
> > > Courses in English and German
> > >
> > > Professional Support for Apache MyFaces
> > >
> >
>
>
> --
>
> http://www.irian.at
>
> Your JSF powerhouse -
> JSF Consulting, Development and
> Courses in English and German
>
> Professional Support for Apache MyFaces
>

Mime
View raw message