myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <>
Subject Re: Focus component enhancement...
Date Fri, 14 Apr 2006 15:22:57 GMT
If "for" is still going to be an attribute, it should continue to mean
"UIComponent that will receive focus".   Otherwise, let's drop "for"
and pick a new attribute name -- it'd be a nightmare to debug support
issues where "for" means two different things, depending on what
version you're working with.

On 4/14/06, Lyon, Chad S. <> wrote:
> Let me run this by everyone.
> I have a suggestion for the focus component.  Let me know what yall think
> before I start working on this.
> Lets change the meaning of the "for" property so that it indicates which
> UIComponent causes the focus component to activate (e.g. generate Javascript
> to focus on page reload) and add another property "value" that indicates the
> UIComponent that will receive focus on page reload.
> This will make it possible to have multiple focus components on pages that
> have multiple controls that need to focus different UIComponents.
> Chad Lyon
> Application Software Developer
> Science Applications International Corporation (SAIC)

View raw message