myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <mkien...@gmail.com>
Subject Re: Problem with Pre-Release 1.1.2
Date Fri, 07 Apr 2006 17:55:34 GMT
On 4/7/06, Sean Schofield <sean.schofield@gmail.com> wrote:
> Mike wrote,
> > You will also need to update your tomahawk and sandbox jars if you are
> > using them.   Up to 1.1.2, tomahawk and sandbox have to be the same
> > version as myfaces-impl.
>
> Is this really true now?  With the new myfaces shared strategy there
> should be no conflict between the impl and tomahawk.
>
> Another possible explanation for a problem is if you are using an old
> myfaces-all.jar.  Once you switch to the new core you will need to
> stop using that and use the tomahawk-1.1.1.jar.


Yes, until tomahawk 1.1.2 is released, you must use the same version
as the myfaces-impl version because there are dependencies on
myfaces-impl classes previous to this release point.

You could use fairly-recent snapshot for tomahawk-only (no sandbox)
components and you'll be ok.  I'm not sure what the cut-over date was,
though.

For sandbox, there is currently no version that is clean of
dependencies on myfaces-impl, although we're getting closer to a clean
version every day.

You definitely cannot use the tomahawk-1.1.1.jar with anything other
than MyFaces 1.1.1.   However, you probably can use the Tomahawk 1.1.2
jar with any version of MyFaces.

Mime
View raw message