myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernd Bohmann <bernd.bohm...@atanion.com>
Subject Re: NBUILD
Date Wed, 19 Apr 2006 15:13:34 GMT
is 3.1 compatible with 2.1?



Matthias Wessendorf schrieb:
> cool to know,
> 
> thx. indeed api requires commons-digester-1,6 which itself requires
> collections-2.1
> 
> Thx,
> Matthias
> 
> On 4/19/06, Bernd Bohmann <bernd.bohmann@atanion.com> wrote:
> 
>>Hi Matthias,
>>
>>from the maven docs:
>>
>>Dependency mediation - this determines what version of a dependency will
>>be used when multiple versions of an artifact are encountered.
>>Currently, Maven 2.0 only supports using the "nearest definition" - so
>>you can always guarantee a version by declaring it explicitly in your
>>project's POM.
>>
>>With mvn -X you see in tiles the dependency to 3.1 is the nearest
>>definition of commons-collection(comes from struts).
>>
>>If you remove the dependency to struts in tiles you get the 2.1 version.
>>I think the dependency comes from myfaces-api.
>>If you need the 3.1 version for tomahawk I would suggest to declare a
>>dependency to 3.1 in the tomahawk core pom. I hope this is the nearest
>>definition :-)
>>
>>Regards
>>
>>Bernd
>>
>>Matthias Wessendorf schrieb:
>>
>>>Bernd any ideas regarding this ?
>>>
>>>interesting is, that the current nbuild examples (simple/blank)
>>>contain 2.1 of collections
>>>but the tiles example containes version 3.1
>>>
>>>-Matthias
>>>
>>>On 4/11/06, Matthias Wessendorf <mwessendorf@gmail.com> wrote:
>>>
>>>
>>>>Hi all,
>>>>
>>>>inside of nbuild is the commons-collection-2.1.jar
>>>>Needed is a 3.x
>>>>==> click on any link in simple.example.war causes
>>>>
>>>><snip>
>>>>java.lang.NoClassDefFoundError: org/apache/commons/collections/map/ReferenceMap
>>>>      org.apache.myfaces.application.jsp.JspStateManagerImpl$SerializedViewCollection.getOldSerializedViewsMap(JspStateManagerImpl.java:762)
>>>></snip>
>>>>
>>>>
>>>>inside of $MYFACES_HOME/core/impl/pom.xml is common-col-3.1.jar refered
>>>>
>>>>perhaps a collection 2.1 dep by another dependency ?
>>>>
>>>>--
>>>>Matthias Wessendorf
>>>>Zülpicher Wall 12, 239
>>>>50674 Köln
>>>>http://www.wessendorf.net
>>>>mwessendorf-at-gmail-dot-com
>>>>
>>>
>>>
>>>
>>>--
>>>Matthias Wessendorf
>>>Aechterhoek 18
>>>48282 Emsdetten
>>>http://jroller.com/page/mwessendorf
>>>mwessendorf-at-gmail-dot-com
>>>
>>
>>--
>>Dipl.-Ing. Bernd Bohmann - Atanion GmbH - Software Development
>>Bismarckstr. 13, 26122 Oldenburg, http://www.atanion.com
>>phone: +49 441 4082312, mobile: +49 173 8839471, fax: +49 441 4082333
>>
> 
> 
> 
> --
> Matthias Wessendorf
> Aechterhoek 18
> 48282 Emsdetten
> http://jroller.com/page/mwessendorf
> mwessendorf-at-gmail-dot-com
> 

-- 
Dipl.-Ing. Bernd Bohmann - Atanion GmbH - Software Development
Bismarckstr. 13, 26122 Oldenburg, http://www.atanion.com
phone: +49 441 4082312, mobile: +49 173 8839471, fax: +49 441 4082333

Mime
View raw message