myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Werner Punz <we...@gmx.at>
Subject Re: maven + eclipse build problem
Date Wed, 08 Mar 2006 09:30:13 GMT
I think I just solved the problem...

after an mvn eclipse:eclipse
you have to add the entries to the shared jars in the projects throwing
errors.
And then if you want to deploy out of eclipse (myeclipse, wtp etc...)
you have to manually set those jars in tomahawk or any other project
referencing it (tomahawk is a perfect point for doing this)
to export (order and export, the checkbox is export)

then the plugin should pick up the jars and export it automatically at a
deployment.

Yiehaaa..


Werner Punz schrieb:
> Werner Punz schrieb:
>> Since the reorg there seem to be dummy packages, now I run into the
>> problem, that I can compile without errors, because the dummy source
>> packages are referenced, but I cannot deploy from eclipse for exactly
>> the same reason, in the builds the dummy packages are renamed to their
>> real release names, and the compiled classes seem to still reference
>> the dummy packages (mainly something like _commons)
>>
>> I have not found a real workaround to this problem yet, does anyone know.
>>
>> I guess dumping the jars with the dummy packages into the webapp is a
>> no option, and so far also no luck with the eclipse maven plugin to
>> bypass this problem :-(
>>
>>
> To sum the problem up, eclipse does no myfaces precompile to rename the
> dummy references, I am currently trying to fix this with a maven plugin
> build step afterwards on the entire myfaces with a clean before, but the
> situation is highly annoying.
> 
> 


Mime
View raw message