myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Aranda <brunoara...@gmail.com>
Subject Re: Building MyFaces
Date Tue, 22 Nov 2005 14:44:23 GMT
Sorry, when I get obsessed with an idea, my lonely neuron stops... ;-)
However I've just run the build without problems. Have you tried to
clean everything first? It seems to me that there is already a folder
simple.war or the build creates it (I don't know why), so it says is
not a file?

Bruno

2005/11/22, James Mitchell <jmitchell@apache.org>:
> --- build/build.xml ---
> ...
> <project name="myfaces-release" default="dist-all" >
>                                          ^^^^^^^^
> ...
> ...
> --- build/build.xml ---
>
>
>
> I'm just running 'ant', so yes.  Is that not what I'm suppose to do?
>
>
>
>
> --
> James Mitchell
> Software Engineer / Open Source Evangelist
> Consulting / Mentoring / Freelance
> EdgeTech, Inc.
> http://www.edgetechservices.net/
> 678.910.8017
> AIM:   jmitchtx
> MSN:   jmitchell@apache.org
> Skype: jmitchtx
>
> ----- Original Message -----
> From: "Bruno Aranda" <brunoaranda@gmail.com>
> To: "MyFaces Development" <dev@myfaces.apache.org>
> Sent: Tuesday, November 22, 2005 9:23 AM
> Subject: Re: Building MyFaces
>
>
> Are you running the "dist-all" target? I don't see it...
>
> > $ ant dist-all
>
> Bruno
>
> 2005/11/22, James Mitchell <jmitchell@apache.org>:
> > Yes, that's what I did.
> >
> >
> > > jmitchell@compaq ~/svn/myfaces
> > > $ cd build/
> > >
> > > jmitchell@compaq ~/svn/myfaces/build
> > > $ ant
> >
> > Did I do something wrong?
> >
> >
> > --
> > James Mitchell
> > Software Engineer / Open Source Evangelist
> > Consulting / Mentoring / Freelance
> > EdgeTech, Inc.
> > http://www.edgetechservices.net/
> > 678.910.8017
> > AIM:   jmitchtx
> > MSN:   jmitchell@apache.org
> > Skype: jmitchtx
> >
> > ----- Original Message -----
> > From: "Bruno Aranda" <brunoaranda@gmail.com>
> > To: "MyFaces Development" <dev@myfaces.apache.org>
> > Sent: Tuesday, November 22, 2005 8:47 AM
> > Subject: Re: Building MyFaces
> >
> >
> > You should execute 'ant dist-all' to build everything. And 'ant dist'
> > to build one specific subproject (inside the subproject/build folder).
> > All subprojects and main have the same build (one build to rule them
> > all), so ant dist-all is the specific target to build everything from
> > the main build folder...
> >
> > Regards,
> >
> > Bruno
> >
> > 2005/11/22, James Mitchell <jmitchell@apache.org>:
> > > jmitchell@compaq ~/svn
> > > $ cd myfaces
> > >
> > > jmitchell@compaq ~/svn/myfaces
> > > $ ll
> > > total 0
> > > drwxr-xr-x+  5 jmitchell None 0 Nov  4 22:42 api
> > > drwxr-xr-x+  7 jmitchell None 0 Nov  4 22:42 build
> > > drwxr-xr-x+ 11 jmitchell None 0 Nov  4 22:42 examples
> > > drwxr-xr-x+  6 jmitchell None 0 Oct 26 22:51 forrest
> > > drwxr-xr-x+  6 jmitchell None 0 Oct 26 22:48 impl
> > > drwxr-xr-x+  2 jmitchell None 0 Oct 26 23:01 lib
> > > drwxr-xr-x+  7 jmitchell None 0 Oct 26 22:49 sandbox
> > > drwxr-xr-x+  4 jmitchell None 0 Oct 26 22:51 share
> > > drwxr-xr-x+  7 jmitchell None 0 Oct 26 22:50 tomahawk
> > >
> > > jmitchell@compaq ~/svn/myfaces
> > > $ cd build/
> > >
> > > jmitchell@compaq ~/svn/myfaces/build
> > > $ ant
> > > Buildfile: build.xml
> > >
> > > download-dependencies:
> > >       [get] Getting:
> > > http://www.ibiblio.org/maven/commons-beanutils/jars/commons-beanutils-1.6.1.jar
> > >       [get] To:
> > > C:\cygwin\home\jmitchell\svn\myfaces\lib\commons-beanutils.jar
> > > ...
> > > ...
> > > (snip)
> > > ...
> > > ...
> > > subproject:
> > >      [echo] suproject : examples
> > >      [echo] properties: examples/build.properties
> > > ...
> > > ...
> > > (snip)
> > > ...
> > > ...
> > > BUILD FAILED
> > > C:\cygwin\home\jmitchell\svn\myfaces\build\build.xml:790: The following
> > > error occurred while executing this line:
> > > C:\cygwin\home\jmitchell\svn\myfaces\build\build.xml:438: The following
> > > error occurred while executing this line:
> > > C:\cygwin\home\jmitchell\svn\myfaces\build\build.xml:404: The following
> > > error occurred while executing this line:
> > > C:\cygwin\home\jmitchell\svn\myfaces\examples\build\build.xml:859: The
> > > following error occurred while executing this line:
> > > C:\cygwin\home\jmitchell\svn\myfaces\examples\build\build.xml:904:
> > > C:\cygwin\home\jmitchell\svn\myfaces\examples\build\dist\simple.war is
> > > not
> > > a
> > > file.
> > >
> > > Total time: 23 minutes 39 seconds
> > >
> > > ----
> > >
> > > No compile or test errors, it just doesn' work.
> > >
> > > This worked fine for me a few days ago.  Did I miss something recently?
> > >
> > >
> > >
> > > --
> > > James Mitchell
> > > Software Engineer / Open Source Evangelist
> > > Consulting / Mentoring / Freelance
> > > EdgeTech, Inc.
> > > http://www.edgetechservices.net/
> > > 678.910.8017
> > > AIM:   jmitchtx
> > > MSN:   jmitchell@apache.org
> > > Skype: jmitchtx
> > >
> > >
> > >
> >
> >
> >
>
>
>

Mime
View raw message