myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manfred Geiler <manfred.gei...@gmail.com>
Subject Re: Java 5 code in Sandbox ?
Date Fri, 09 Sep 2005 10:43:13 GMT
Just a sidenote:
According to the spec the JSF 1.1 container itself must even be
compatible to J2SE 1.3 !
Of course, this is no requirement for custom components.
But, we should keep in mind, that the J2EE world is spinning a little
bit slower than the J2SE client world...
;-)
-Manfred

2005/9/8, Werner Punz <werpu@gmx.at>:
> Mathias Brökelmann wrote:
> > Just a note. JDK1.5 is able to produce 1.4 classes. We could change
> > the build process to let the user choose which target he needs and
> > still provide 1.4 classes (or both) in the releases. But let us bring
> > the next release out before going that way.
> >
> Maintenance nightmare, I would not want to keep two codebases
> in the long run.
> I have moved from two projects from 1.4 to 1.5 and believe me, once
> you made the switch and have started to use the new constructs,
> it is close to impossible to go back, the backporting effort
> is too big, once you have reached a certain point, which for sure you
> will reach soon enough.
> 
>

Mime
View raw message