myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Smith <gra...@marathon-man.com>
Subject Re: SVN Reorg (Update)
Date Mon, 11 Jul 2005 18:27:37 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
I was actually ant tlddoc-all from the main build. There is definitely
an OS-specific problem here in expanding the wildcard *.tld. I don't
think you can specify a wildcard to the tlddoc task under Linux.<br>
I propose just putting the actual full tld filenames into the tlddoc
task for each subproject.<br>
<br>
Any objections ?<br>
<br>
<br>
Bruno Aranda wrote:
<blockquote cite="mid1a681ff2050711103938957792@mail.gmail.com"
 type="cite">
  <pre wrap="">Grant, are you running 'ant dist' on the sandbox build folder, aren't
you? I've run into this problem before. It seems that when you only
build one of the subprojects, the file build.properties of the
subproject (situated in the subproject parent folder) is not read. In
the build.properties there are some properties that tell which are the
resource files to include (in our case the *.tlds). If this property
is not read, it use dummy values (e.g. *.foo) so the build fails.
What is more interesting is that yesterday I try to build only sandbox
to check if this bug had disappear and everything went ok... but, I
was trying in a Windows XP. Here at work I run a linux box and the
build fails.
I think that this could be solved if the properties from
build.properties were read before the dummy ones in the build.xml,
because ant keeps the value from the first property read and does not
override it,

HTH,

Bruno

2005/7/11, Grant Smith <a class="moz-txt-link-rfc2396E" href="mailto:grants@marathon-man.com">&lt;grants@marathon-man.com&gt;</a>:
  </pre>
  <blockquote type="cite">
    <pre wrap="">Doh!

Bruno, thanks.  OK, so now it looks like it's trying to find a file
called *.tld (i.e. the wildcard isnt being interpretted). That is where
I'm focussing my investigation on now :)

Bruno Aranda wrote:

    </pre>
    <blockquote type="cite">
      <pre wrap="">I think you are missing the temp in
ls -la
/home/grant/IdeaProjects/myfaces/current/build/../sandbox/build/tlds

should be
ls -la /home/grant/IdeaProjects/myfaces/current/build/../sandbox/build/temp/tlds

Regards :-)

Bruno


      </pre>
    </blockquote>
    <pre wrap="">

    </pre>
  </blockquote>
  <pre wrap=""><!---->
.

  </pre>
</blockquote>
<br>
</body>
</html>

Mime
View raw message