myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Schofield <sean.schofi...@gmail.com>
Subject Re: MyFaces and Portlets [ was RE: Problem with TLD in new App Distro]
Date Tue, 05 Jul 2005 16:15:20 GMT
Stan,

When you get a chance can you take a look at the portal stuff
(post-reorg).  I can't remember but I don't think everything that
needs to be built is being built yet in the new ant script.  Maybe you
could try doing a new build and see what's missing?

sean

ps. If you patch the build, try to stick to the convention of creating
targets such as 'foo-all' and 'foo' that I described in an earlier
email.

On 7/5/05, Stan Silvert <stan.silvert@jboss.com> wrote:
> Thanks Paul.  I've passed this on to the JBoss Portal team.
> 
> Stan Silvert
> JBoss, Inc.
> ssilvert@jboss.com
> callto://stansilvert
> 
> > -----Original Message-----
> > From: Paul Holmes-Higgin [mailto:paul.holmes-higgin@alfresco.org]
> > Sent: Monday, July 04, 2005 4:42 AM
> > To: MyFaces Development
> > Subject: RE: MyFaces and Portlets [ was RE: Problem with TLD in new
> App
> > Distro]
> >
> > Stan
> >
> > As you know, we make full use of MyFaces and Jboss Portal, so we'd
> like
> > to add our congrats too - and are happy to help out if we can.
> >
> > You ask for feedback.  Well, the main piece that is missing for us is
> > being able to use the upload component in portlets - we have to step
> > outside JSF, which really limits what we can do.  I know it's a
> > low-level problem, and that JSR-168 has no help for us, but getting a
> > decent solution is important for real apps.
> >
> > Cheers
> > Paul.
> >
> > ---
> > Paul Holmes-Higgin
> > Alfresco.org
> > Email: paulhh@alfresco.org
> >
> > > -----Original Message-----
> > > From: Stan Silvert [mailto:stan.silvert@jboss.com]
> > > Sent: 03 July 2005 22:19
> > > To: MyFaces Development; Manfred Geiler; Bruno Aranda
> > > Subject: MyFaces and Portlets [ was RE: Problem with TLD in
> > > new App Distro]
> > >
> > > > So, this is also the right place to congratulate and thank Stan
> for
> > > > his brilliant Portlet/MyFaces Session at the JavaOne.
> > > > For those who where not there: The Yerba Buena Theatre was full to
> > > > bursting - must have been 500-1000 people -  wow!
> > >
> > > Thanks Manfred.  You are too kind.
> > >
> > > I have blogged about the presentation with a short summary of
> > > things you need to know if you want to try the demo stuff at
> > > home.  In the next few days I'll be blogging more on this and
> > > on the JBoss inclusion of MyFaces in 4.0.3.
> > >
> > > http://jboss.org/jbossBlog/blog/Stan%20Silvert/2005/07/01/Foll
> > ow_up_to_m
> > > y_JavaOne_talk.txt
> > >
> > > Also, the preliminary scoop on the MyFaces/JBoss stuff is here:
> > > http://wiki.jboss.org/wiki/Wiki.jsp?page=JBossFaces
> > >
> > > I'll be putting a newer version of MyFaces into the final
> > > 4.0.3 build, but any feedback you can give before that is
> > > greatly appreciated.
> > >
> > > Stan Silvert
> > > JBoss, Inc.
> > > ssilvert@jboss.com
> > > callto://stansilvert
> > >
> > > > -----Original Message-----
> > > > From: Manfred Geiler [mailto:manfred.geiler@gmail.com]
> > > > Sent: Saturday, July 02, 2005 4:13 PM
> > > > To: MyFaces Development; Bruno Aranda
> > > > Subject: Re: Problem with TLD in new App Distro
> > > >
> > > > So, this is also the right place to congratulate and thank Stan
> for
> > > > his brilliant Portlet/MyFaces Session at the JavaOne.
> > > > For those who where not there: The Yerba Buena Theatre was full to
> > > > bursting - must have been 500-1000 people -  wow!
> > > >
> > > > -Manfred
> > > >
> > > >
> > > > 2005/7/1, Bruno Aranda <brunoaranda@gmail.com>:
> > > > > I found the source of my 'problem'. I was doing the tests with
> > > > > jboss4.0.3RC1 and I've remembered that Stan announced
> > > several weeks
> > > > > ago that jboss4.0.3 would include myfaces.
> > > > > Jboss4.0.3RC1 has been released with myfaces 1.0.9 version (I
> > > guess).
> > > > > Be warned those who are using newer myfaces from the svn trunk
> as,
> > > by
> > > > > default, jboss loads the older myfaces and some things might not
> > > work.
> > > > > However, it is good news indeed that jboss has included
> > > myfaces! :-)
> > > > >
> > > > > Regards,
> > > > >
> > > > > Bruno
> > > > >
> > > > > 2005/6/30, Sean Schofield <sean.schofield@gmail.com>:
> > > > > > OK I've identified the problem.  Now that I have had a decent
> > > night
> > > > > > sleep and looked at it again I noticed that the
> > > sandbox.jar is now
> > > > > > part of WEB-INF/lib.  I had forgotten that.  Anyways
> > > that jar also
> > > > > > contains a TLD with the same URI and since that one is
> > > alphabetical
> > > > > > before tomahawk.jar that is the one that is loaded first.
> > > > > >
> > > > > > I'll fix things and check it in.
> > > > > >
> > > > > > sean
> > > > > >
> > > > > > On 6/30/05, Sean Schofield <sean.schofield@gmail.com>
wrote:
> > > > > > > Also,
> > > > > > >
> > > > > > > I've compared the myfaces_ext.tld with the one in
> myfaces.jar
> > > (which
> > > > > > > works) and the one in tomahawk.jar (which does not work)
and
> > > they
> > > > are
> > > > > > > identical!
> > > > > > >
> > > > > > > sean
> > > > > > >
> > > > > > > On 6/30/05, Sean Schofield <sean.schofield@gmail.com>
wrote:
> > > > > > > > Are you using Tomcat 5.0?  Maybe its a Tomcat problem.
 If
> > > anyone
> > > > is
> > > > > > > > willing to help out I can send you the WAR file (or
the
> > > > instructions
> > > > > > > > to build it.)
> > > > > > > >
> > > > > > > > sean
> > > > > > > >
> > > > > > > > On 6/30/05, Bruno Aranda <brunoaranda@gmail.com>
wrote:
> > > > > > > > > A strange problem indeed, I don't see this problem
with
> > > tree2,
> > > > but
> > > > > > > > > with selectManyMenu...
> > > > > > > > >
> > > > > > > > > /displayValueOnly.jsp(67,3) No tag
> > > "selectManyMenu" defined
> > > in
> > > > tag
> > > > > > > > > library imported with prefix "x"
> > > > > > > > >
> > > > > > > > > tree2 is show ok in my computer....
> > > > > > > > >
> > > > > > > > > Bruno
> > > > > > > > >
> > > > > > > > > 2005/6/30, Sean Schofield <sean.schofield@gmail.com>:
> > > > > > > > > > I've run into a bizarre problem with the
new app
> distro.
> > > I'm
> > > > getting
> > > > > > > > > > errors such as:
> > > > > > > > > >
> > > > > > > > > > javax.servlet.ServletException:
> /tree2NiceWrap.jsp(36,8)
> > > No
> > > > tag
> > > > > > > > > > "tree2" defined in tag library imported
with prefix
> "x"
> > > > > > > > > >
> > > > > > > > > > The only thing different is that the myfaces
> > > stuff in the
> > > > examples app
> > > > > > > > > > is now in three jars (myfaces-api.jar,
> myfaces-impl.jar
> > > and
> > > > > > > > > > tomahawk.jar).  So the TLD's are split across
> > > jars.  The
> > > > > > > > > > myfaces_ext.tld is in tomahawk.jar now.
> > > > > > > > > >
> > > > > > > > > > If I copy the old myfaces.jar (which has
everything)
> and
> > > use
> > > > that
> > > > > > > > > > instead things work fine.  What's even stranger
> > > is that it
> > > > seems that
> > > > > > > > > > it started working once I removed it and
> > > switched back to
> > > the
> > > > old
> > > > > > > > > > jars.  I've tried clearing the work directory,
etc.
> but
> > > can't
> > > > figure
> > > > > > > > > > it out.
> > > > > > > > > >
> > > > > > > > > > There must be an obvious explanation I am
missing
> here.
> > > > > > > > > >
> > > > > > > > > > sean
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > >
>

Mime
View raw message