myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Dudney <bdud...@mac.com>
Subject Re: Tomcat 5.5
Date Tue, 31 May 2005 17:23:28 GMT
Hi Sean,

On May 31, 2005, at 10:57 AM, Sean Schofield wrote:

> IMO there are two issues here:
>
> 1.) What is required to run MyFaces (in general - not specifically our
> examples bundle) on the various Tomcat versions?
>
> 2.) How to make the examples work on the various deployments.
>

Agreed, we need two docs. The 'getting-started' doc appears addresses  
point 2 (except for tomcat 4.x and I'll address that) and we need an  
additional one that documents point 1.

> They are related but slightly different questions.  It seems like the
> jsp-2.0.jar is the determining factor (although I thought there was
> another.)  It would be nice to have a summary of the various tomcat
> versions (based on your findings above) that describe what jars need
> to be added or removed (to a standard Tomcat distro) for a generic
> MyFaces app to work.

Agreed, not sure why commons-el.jar was an issue but at one point it  
was (I think there was a conflict between the tomcat5.5.x el and the  
commons-el). Anyway it seems that we are down to the jsp-2.0.jar file  
being the problem for tomcat4.x.

In short;

4.x - needs the jsp-2.0.jar file to work
5.x - works out of the box (fresh tomcat 5.x install and our  
downloaded examples)

We should remove the discussion of the commons-el.jar from the docs  
as it is no longer a problem for 5.0.x or 5.5.x.

> You can use the simple examples as a test case
> in determining this but the write up should be focused on any
> application.  That's the question we seem to get more than anything.
> ("I can't get my hello world working on Tomcat version such and such')
>

Agreed, i'll make a table in the doc I write up for point 1 above.

> As for the examples, my opinion on that would depend on the answer to
> the following question.  Do the current examples work on an
> out-of-the-box distro for Tomcat 5 and Tomcat 5.5?  (I believe they
> work on 5.0 b/c that is what I use.)  If they work on both of these
> versions I would say that yes we can ignore special build
> configuration options for the examples since most are running at least
> 5.0.

I'll write up stuff for point 2 that addresses 'pre 5.x' tomcat.

TTFN,

-bd-


Mime
View raw message