myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manfred Geiler <manfred.gei...@gmail.com>
Subject Re: Question about custom render kits
Date Fri, 01 Apr 2005 07:14:53 GMT
Perhaps a bug in the configurator, but it's more likely that he had
some snarls with the default renderer type in his custom component.
-M

On Apr 1, 2005 6:15 AM, Sean Schofield <sean.schofield@gmail.com> wrote:
> One of our users was trying to using their own extended version of
> tree2.  In their faces-config.xml (their version, not the default one
> in the jar) they had the following ...
> 
>  <component>
>    <component-type>org.apache.myfaces.HtmlTree2</component-type>
>    <component-class>org.objectsource.ui.UITree</component-class>
>  </component>
> 
> So basically he was just replacing the component class for tree2.
> When he tried to use tree2 in a page he got just a blank page.
> 
> Once he added the following everything worked fine ...
> 
>  <renderer>
>    <component-family>org.apache.myfaces.HtmlTree2</component-family>
>    <renderer-type>org.apache.myfaces.HtmlTree2</renderer-type>
>    <renderer-class>org.apache.myfaces.custom.tree2.HtmlTreeRenderer</renderer-class>
>  </renderer>
> 
> This is the *same* renderer block as in the default faces-config.xml
> that is inside the jar.  The user is reporting that MyFaces is
> requiring the renderer to specified in the user's faces-config.xml
> file if the component is overridden there.
> 
> Is that true?  If so, is that a MyFaces bug/limitation or is that in
> the specification somewhere?
> 
> sean
>

Mime
View raw message