myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Schofield <sean.schofi...@gmail.com>
Subject Re: Another bug in h:selectBooleanCheckbox while embeded in a x:dataTable
Date Thu, 10 Feb 2005 15:10:57 GMT
I just took a look at the original tabbed pane example.  Now that I am
thinking about it, I think what I saw was expected behavior.  All
three tabs are to be submitted when you press the "common" submit
button.  It might be a nice improvement to change the active tab to
the page that has the validation error, but that is another issue.

I'm at work now so I will have to wait until tonight to look at your
example again.  I think I have convinced the powers that be here to
open the firewall so I can get latest CVS code which will help me out
tremendously :-)

Based on the example on the website, it seems that at lesat in some
cases, the submitted values are being provided to the child
components.  I say this because I can type values in the text fields
and after I submit, they are still there.  It also seems to be mapping
the submission values to the correct components (again at least with
h:inputText.)

Perhaps this is a bug with the implementation of
h:selectBooleanCheckbox.  I do not have a lot of experience with that
one but I will start there when I get home tonight.  Have you verified
that h:selectBooleanCheckbox works as you expect without the tabPanel
or dataTable?

sean


On Thu, 10 Feb 2005 10:38:41 -0400, Sylvain Vieujot <svieujot@apache.org> wrote:
>  Hello Sean,
>  
>  No, I didn't notice this - and I didn't fill in vales in the input fields.
>  As far as I'm concerned, you can remove the inputText fields anyway, as the
> bug I get only concerns the radio buttons losing their state.
>  
>  I guess those are 2 separate issues (but maybe related).
>  
>  Thanks,
>  
>  Sylvain.
> 
>  
>  On Thu, 2005-02-10 at 09:22 -0500, Sean Schofield wrote: 
>  Sylvain, I downloaded your latest code. I am making progress. I get an
> error when I submit on the third tab, however. Validation Error: "inp2":
> Value is required. Are you getting the same error? I looked (briefly) at
> your jsp and noticed that inp2 corresponds to a <h:inputText> component on
> the *first* tab. My guess is that the component is getting confused as to
> which tab you are currently on. If you are not getting this error I would
> guess its because you are filling in values on the first page before
> submitting. Is that a requirement? I would think that only the active tab is
> submitted. Anyways, those are some ideas to go on. I will await your
> response and then do some more investigating once I have some more details
> from you about the expected behavior and whether or not you have this
> validation error as well. Also, Michael Wiedmann reported a problem with
> <h:commandLink> not working inside the panelTab. Could be related ... sean
> On Wed, 9 Feb 2005 12:45:48 -0500, Sean Schofield <sean.schofield@gmail.com>
> wrote: > Sylvain, > > Thanks for committing. The branch is called
> 'new-tree-branch'. Just > checkout with -r new-tree-branch. > > sean > >
>
> On Wed, 09 Feb 2005 13:42:36 -0400, Sylvain Vieujot <sv@freelance.com>
> wrote: > > Hello Sean, > > > > MYFACES-104's patch has been submitted.
> > >
> > As for your branch, where do I find it ? > > I don't find any branch in
> the CVS. > > > > Sylvain. > > > > > > On Wed, 2005-02-09
at 11:32 -0500,
> Sean Schofield wrote: > > Sylvain, I will take a look at your revised code
> tonight. Can you commit my > > branch stuff? Also we have a couple of users
> waiting on the commit for > > MYFACES-104 (that should go on the trunk).
> Thanks, sean On Wed, 09 Feb 2005 > > 12:29:35 -0400, Sylvain Vieujot
> <sv@freelance.com> wrote: > Yes, I just saw > > I forgot to commit this
> file. > I just committed it. > Sorry for that, and > > thanks for the
> message. > > Sylvain. > > > On Wed, 2005-02-09 at 11:21 > > -0500,
Sean
> Schofield wrote: > Sylvain, I keep getting the NPE whenever I > > click on a
> tab. I also noticed > the following in the log: 2005-02-09 > > 10:13:21,269
> [http-8080-Processor4] > WARN > > org.apache.myfaces.el.VariableResolverImpl
> - Variable 'testCheckBox' > could > > not be resolved. 2005-02-09
> 10:13:21,279 [http-8080-Processor4] WARN > > >
> org.apache.myfaces.el.VariableResolverImpl - Variable 'testCheckList' could
> > > > not be resolved. Maybe some of the managed beans are missing in > >
>
> examples-config.xml? I am at work now so I cannot check very easily but I >
> > > will check when I get home. Also, I was working on the branch but I
> believe > > > the branch was created after you updated your examples page so
> that > > > shouldn't be a problem. sean >

Mime
View raw message