mxnet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marco de Abreu <marco.g.ab...@googlemail.com.INVALID>
Subject Re: C++ api issue labeling
Date Thu, 12 Jul 2018 07:37:29 GMT
+1 to combining feature and feature request

Haibin Lin <haibin.lin.aws@gmail.com> schrieb am Do., 12. Juli 2018, 10:15:

> +1 merging "feature" with "feature request"
>
> On Tue, Jul 10, 2018 at 12:59 PM, Anirudh Acharya <anirudhkrec@gmail.com>
> wrote:
>
> > There is another instance of label duplication - We have labels
> "Feature" (
> > https://github.com/apache/incubator-mxnet/labels/Feature ) and "Feature
> > Request" (
> > https://github.com/apache/incubator-mxnet/labels/Feature%20request ). I
> > don't think there is much difference between these two labels.
> >
> > It would make sense to merge the "Feature" label into "Feature Request".
> >
> >
> > Thanks
> > Anirudh
> >
> >
> > On Wed, Jun 27, 2018 at 3:50 PM Hagay Lupesko <lupesko@gmail.com> wrote:
> >
> > > Thank you everyone for your suggestions.
> > > I will work with a committer to get this updated ASAP.
> > >
> > > On Mon, Jun 25, 2018 at 8:55 AM Marco de Abreu
> > > <marco.g.abreu@googlemail.com.invalid> wrote:
> > >
> > > > +1 to renaming to Backend
> > > >
> > > > On Mon, Jun 25, 2018 at 10:13 AM Hagay Lupesko <lupesko@gmail.com>
> > > wrote:
> > > >
> > > > > Thanks Lin for your feedback.
> > > > > Bumping again to get more feedback before concluding.
> > > > >
> > > > > On Fri, Jun 22, 2018 at 8:53 AM Lin Yuan <apeforest@gmail.com>
> > wrote:
> > > > >
> > > > > > I agree with Hagay. Using "Backend" as label makes it much easier
> > to
> > > > > track.
> > > > > >  "C++" label only describes the language used in implementation,
> > > > > "Backend"
> > > > > > better describes the nature of the work (let's assume we change
> the
> > > > > backend
> > > > > > implementation from C++ to other languages in the future).
> > > > > >
> > > > > > Lin
> > > > > >
> > > > > > On Fri, Jun 22, 2018 at 1:09 AM Hagay Lupesko <lupesko@gmail.com
> >
> > > > wrote:
> > > > > >
> > > > > > > Thanks everyone for chiming in and clarifying.
> > > > > > > It seems that the "C++" label name is confusing for our
> community
> > > > since
> > > > > > it
> > > > > > > can be interpreted as both the CPP API and the backend...
> > > > > > > As an anecdote, this issue [1
> > > > > > > <https://github.com/apache/incubator-mxnet/issues/10937>]
is
> > > labeled
> > > > > as
> > > > > > > "C++" but is about the CPP API, not the backend.
> > > > > > >
> > > > > > > Should we just rename "C++" to "Backend" to avoid confusion?
> > > > > > >
> > > > > > > [1] https://github.com/apache/incubator-mxnet/issues/10937
> > > > > > >
> > > > > > > On Thu, Jun 21, 2018 at 12:39 PM Pedro Larroy <
> > > > > > > pedro.larroy.lists@gmail.com>
> > > > > > > wrote:
> > > > > > >
> > > > > > > > Agree with Anirudh, they are different things. Maybe
change
> the
> > > > "C++"
> > > > > > > label
> > > > > > > > to "backend" would be more informative?
> > > > > > > >
> > > > > > > > On Thu, Jun 21, 2018 at 12:11 PM Anirudh <
> > anirudh2290@gmail.com>
> > > > > > wrote:
> > > > > > > >
> > > > > > > > > Hi Hagay,
> > > > > > > > >
> > > > > > > > > I think we should keep these two labels seperate
since they
> > > mean
> > > > > > > > different
> > > > > > > > > things.
> > > > > > > > > The C++ label refers to the issue for MXNet backend
and the
> > CPP
> > > > > > package
> > > > > > > > > refers to the CPP language binding for mxnet.
> > > > > > > > > We can still make C++ API great again irrespective
by
> > filtering
> > > > out
> > > > > > CPP
> > > > > > > > > package issues :).
> > > > > > > > >
> > > > > > > > > Anirudh
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > On Thu, Jun 21, 2018 at 11:56 AM, Hagay Lupesko
<
> > > > lupesko@gmail.com
> > > > > >
> > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > > Hey community,
> > > > > > > > > >
> > > > > > > > > > I was going over the open GitHub issues
for MXNet, and
> > > noticed
> > > > > that
> > > > > > > we
> > > > > > > > > have
> > > > > > > > > > two labels for the CPP API: "CPP package",
"C++"
> > > > > > > > > >
> > > > > > > > > > Wanted to suggest we remove "CPP package"
and just stick
> to
> > > > "C++"
> > > > > > > > > > This will make it easier for the community
to classify
> > issues
> > > > and
> > > > > > > focus
> > > > > > > > > on
> > > > > > > > > > making the C++ API great again ;)
> > > > > > > > > >
> > > > > > > > > > Let me know if someone has any concerns,
otherwise I will
> > > find
> > > > a
> > > > > > > > > committer
> > > > > > > > > > that I can work with to make this change.
> > > > > > > > > >
> > > > > > > > > > Thanks!
> > > > > > > > > > Hagay
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message