mxnet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shiwen hu <yajiedes...@gmail.com>
Subject Re: who know what version cmake in our windwos ci?
Date Fri, 06 Oct 2017 01:27:14 GMT
Reference resources my cmake issue
https://gitlab.kitware.com/cmake/cmake/issues/17313

2017-10-06 9:25 GMT+08:00 shiwen hu <yajiedesign@gmail.com>:

> set the minimum CMake requirements for MXNet users to 3.9 or minimum
> required 3.8, but I haven't tested 3.8
> because need to use this function https://cmake.org/
> cmake/help/latest/release/3.8.html?highlight=cuda
> and the old FindCUDA(our now use) not work in vs2017,
>
> 2017-10-06 3:02 GMT+08:00 kellen sunderland <kellen.sunderland@gmail.com>:
>
>> Just to clarify Shiwen, are you proposing to use CMake 3.9 on our CI, or
>> to
>> set the minimum CMake requirements for MXNet users to 3.9?
>>
>> To give us some more context could you provide a link to a document
>> describing what the problem is, or give us the error that will result from
>> using the wrong version?
>>
>> On Thu, Oct 5, 2017 at 5:59 PM, shiwen hu <yajiedesign@gmail.com> wrote:
>>
>> > the cmake  first-class CUDA  and vs2017 must 3.9
>> > the old cmake CUDA can't work with vs2017.And cmake recommends using the
>> > new approach.
>> >
>> > 2017-10-05 12:40 GMT+08:00 Chris Olivier <cjolivier01@gmail.com>:
>> >
>> > > What file requires cmake 3.9? Why? That’s a pretty steep requirement.
>> > >
>> > > On Wed, Oct 4, 2017 at 9:15 PM shiwen hu <yajiedesign@gmail.com>
>> wrote:
>> > >
>> > > > Preparing for cuda9.0 and vs2017 and update the first-class CUDA
>> with
>> > > > cmake.but it must  version 3.9 cmake.who know what version cmake in
>> our
>> > > > windwos ci now?
>> > > >
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message