mxnet-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [incubator-mxnet] nikudyshko edited a comment on issue #16741: Error detecting C++11 and C++14
Date Fri, 15 Nov 2019 22:41:18 GMT
nikudyshko edited a comment on issue #16741: Error detecting C++11 and C++14
URL: https://github.com/apache/incubator-mxnet/issues/16741#issuecomment-554557267
 
 
   @larroy  I guess, I've found a place, where error occurs. 
   In file ```CMakeLists.txt``` there are following lines: 
   ```include(cmake/ChooseBlas.cmake)
   if(USE_CUDA AND FIRST_CUDA) 
     include(3rdparty/mshadow/cmake/Utils.cmake)
     include(cmake/FirstClassLangCuda.cmake)
     include_directories(${CMAKE_CUDA_TOOLKIT_INCLUDE_DIRECTORIES}) 
   ``` 
   In the file ```FirstClassLangCuda.cmake``` there are calls: 
   ```include(CheckCXXCompilerFlag)
   check_cxx_compiler_flag("-std=c++11"   SUPPORT_CXX11)
   if(USE_CXX14_IF_AVAILABLE)
     check_cxx_compiler_flag("-std=c++14"   SUPPORT_CXX14)
   endif() 
   ``` 
   And that's where error appears. If I change ```-std=c++11``` to ```/std:c++14``` dection
is successfull. (It looks like, that VS2015, VS2017 and VS2019 doesn't support ```/std:c++11```,
that's why I used ```/std:c++14``` for testing)

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message