mxnet-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] jerrin92 opened a new issue #8874: mxnet installation from source: C++ linkage error on HPC
Date Thu, 01 Jan 1970 00:00:00 GMT
jerrin92 opened a new issue #8874: mxnet installation from source: C++ linkage error on HPC
URL: https://github.com/apache/incubator-mxnet/issues/8874
 
 
   
   Tried building mxnet from source on our HPC machine. However, the make fails with the error
message,
   
   ~~~~~~~~~~~~~~~~~~~~~~
   /opt/gcc/5.3.0/snos/include/g++/complex:1873:3: error: template with C linkage
      template<typename _Tp, typename _Up>
      ^
   /opt/gcc/5.3.0/snos/include/g++/complex:1884:3: error: template with C linkage
      template<typename _Tp> std::complex<_Tp> proj(const std::complex<_Tp>&);
      ^
   /opt/gcc/5.3.0/snos/include/g++/complex:1886:3: error: template with C linkage
      template<typename _Tp>
      ^
   /opt/gcc/5.3.0/snos/include/g++/complex: In function '__complex__ double std::__complex_proj(__complex__
double)':
   /opt/gcc/5.3.0/snos/include/g++/complex:1903:40: error: conflicting declaration of C function
'__complex__ double std::__complex_proj(__complex__ double)'
      __complex_proj(__complex__ double __z)
                                           ^
   /opt/gcc/5.3.0/snos/include/g++/complex:1899:3: note: previous declaration '__complex__
float std::__complex_proj(__complex__ float)'
      __complex_proj(__complex__ float __z)
      ^
   ~~~~~~~~~~~~~~~~~~~~~~
   
   
   
   ## Environment info (Required)
   
   ----------Python Info----------
   ('Version      :', '2.7.8')
   ('Compiler     :', 'GCC 4.9.1 20140716 (Cray Inc.)')
   ('Build        :', ('default', 'Dec  8 2014 16:10:59'))
   ('Arch         :', ('64bit', 'ELF'))
   ------------Pip Info-----------
   ('Version      :', '9.0.1')
   ('Directory    :', '/N/soft/cle4/python/2.7.8/lib/python2.7/site-packages/pip')
   ----------MXNet Info-----------
   No MXNet installed.
   ----------System Info----------
   ('Platform     :', 'Linux-3.0.101-0.47.106.8-default-x86_64-with-SuSE-11-x86_64')
   ('system       :', 'Linux')
   ('node         :', 'login2')
   ('release      :', '3.0.101-0.47.106.8-default')
   ('version      :', '#1 SMP Wed Oct 11 18:58:12 UTC 2017 (4355936)')
   ----------Hardware Info----------
   ('machine      :', 'x86_64')
   ('processor    :', 'x86_64')
   Architecture:          x86_64
   CPU op-mode(s):        32-bit, 64-bit
   Byte Order:            Little Endian
   CPU(s):                32
   On-line CPU(s) list:   0-31
   Thread(s) per core:    2
   Core(s) per socket:    4
   Socket(s):             4
   NUMA node(s):          1
   Vendor ID:             AuthenticAMD
   CPU family:            21
   Model:                 1
   Stepping:              2
   CPU MHz:               2600.290
   BogoMIPS:              5200.86
   Virtualization:        AMD-V
   L1d cache:             16K
   L1i cache:             64K
   L2 cache:              2048K
   L3 cache:              6144K
   NUMA node0 CPU(s):     0-31
   
   We have a Cuda 7.5 and Cudnnv5 for the cuda.
   
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message