mina-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ole Schaper ...@splitscreenstudios.com>
Subject Re: Update from M3 to M4 send timeout problems
Date Thu, 22 Jan 2009 13:15:44 GMT
Since it seems that I am the only one with this problem, here is what I 
found out:

1. Does not happen using M3
2. Does only happen on Vista
3. Does happen no matter which tcp autotuning, chimney, rss, whatnot 
settings
4. Does NOT happen if the server is running on linux
5. Does only happen while sending AND receiving data
6. Does only happen if COMODO Personal Firewall installed (even if it is 
disabled!)

I tried to write a junit test, but I am not able to reproduce it with a 
test, everything is running fine in the tests I wrote. Maybe you guys 
have some more (and better) test to run against this setup (Vista, 
Commodo, M4)?
I tried to figure out what has been changed from M3 to M4 that could 
cause this firewall problem but I think it doesn't make much sense 
(would take ages I suppose). So if anyone could tell me what is going on 
here I would be the happiest guy in the world (seriously!)

Cheers

Ole

Ole Schaper wrote:
> Hi there,
>
> I'm using mina-core-2.0.0-M3 and now I want to update to 
> mina-core-2.0.0-M4 but if I do so, I get a lot of timeouts in my send 
> method:
>
> [...]
> //write to session
> final WriteFuture writeFuture = session.write( msg );
> try {
>   if ( !writeFuture.await( 5, TimeUnit.SECONDS ) ) {
>      logger.error("Send timed out!");
>   }
> } catch ( final InterruptedException e ) {
>    e.printStackTrace();
> }
> [...]
>
> I have no idea what is going on, the M3 release is working fine.
> After a send timed out, it could send some messages again but only 
> until the next Timeout.
> Sender and Receiver are in a LAN, actually even the same machine most 
> of the time.
> If I replace the await() with a join() call, it hangs forever 
> (obviously).
>
> If you need some more information about my setup please let me know.
> Is there something different in handling session.write() from M3 to M4?
> I could not find any bug-report for this issue in the JIRA system.
> Is this a bug or am I missing something?
>
> Thank You very much!
>
> Ole
>


Mime
View raw message