mina-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Falby, Walter" <Walter.Fa...@compuware.com>
Subject RE: Running MINA on z/OS USS
Date Fri, 30 Jan 2009 17:15:06 GMT
I've run two programs using NIO. The server was running on USS and the
client was running on Windows. They can communicate just fine. I don't
have time to research why MINA is not running on USS. It could be an
issue with the version of Java used to build MINA. Or, it could be some
setup issue.

Thanks for your time...Walter


The contents of this e-mail are intended for the named addressee only. It contains information
that may be confidential. Unless you are the named addressee or an authorized designee, you
may not copy or use it, or disclose it to anyone else. If you received it in error please
notify us immediately and then destroy it.

From: Ashish [mailto:paliwalashish@gmail.com] 
Sent: Thursday, January 29, 2009 11:46 PM
To: users@mina.apache.org
Subject: Re: Running MINA on z/OS USS

On Fri, Jan 30, 2009 at 1:27 AM, Falby, Walter
<Walter.Falby@compuware.com> wrote:
> I'm trying to run one of the samples on USS. This is IBM's version of
> UNIX that runs on z/OS (mainframe). I've brought derby over and it
works
> fine. I've compiled the Image request/response sample on USS using
Java
> 5. I've copied over the jar files for MINA and SLF4J. I've updated the
> sample to include debug statements. What happens is the connect
request
> from the client is refused. When I look at the trace on USS, I see the
> application get started. When I run the application on Windows, what I
> see in the trace is a line from the
> org.apache.mina.filter.executor.ExecutorFilter. I don't see that line
in
> the USS trace. This may be a platform issue. Has anyone tried MINA on
> USS running on z/OS 1.10?

Couple of things you can try
1. Try a simple socket program there (not MINA based), just to narrow
down the problem
2. try the sample UDP program from MINA.
3. If nothing works, then would recommend using Eclipse
debugger/wireshark to see what's going on in there.
4. Also, ask System Admins of any there are any specific setting, that
may be causing this

- ashish

- ashish

Mime
View raw message