mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christoph John (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (DIRMINA-1076) Leaking NioProcessors/NioSocketConnectors hanging in call to dispose
Date Fri, 09 Feb 2018 14:30:00 GMT

    [ https://issues.apache.org/jira/browse/DIRMINA-1076?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16358454#comment-16358454
] 

Christoph John edited comment on DIRMINA-1076 at 2/9/18 2:29 PM:
-----------------------------------------------------------------

Java HotSpot(TM) 64-Bit Server VM (25.131-b11 mixed mode)
Ubuntu Linux, Kernel 4.4.0-112-generic
Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
Tested against mina-2.0 from https://github.com/apache/mina/tree/2.0 so should be 2.0.17-SNAPSHOT


I have run the AbstractIoServiceTest from within Eclipse then. :)


was (Author: chrjohn):
Java HotSpot(TM) 64-Bit Server VM (25.131-b11 mixed mode)
Ubuntu Linux, Kernel 4.4.0-112-generic
Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
Tested against mina-2.0 from https://github.com/apache/mina/tree/2.0 so should be 2.0.17-SNAPSHOT


> Leaking NioProcessors/NioSocketConnectors hanging in call to dispose
> --------------------------------------------------------------------
>
>                 Key: DIRMINA-1076
>                 URL: https://issues.apache.org/jira/browse/DIRMINA-1076
>             Project: MINA
>          Issue Type: Bug
>    Affects Versions: 2.0.16
>            Reporter: Christoph John
>            Priority: Major
>         Attachments: mina-dispose-hang.txt, mina-test-patch.txt
>
>
> Follow-up to mailing list discussion.
> I was now able to reproduce the problem with a MINA test. Or let's say I did the brute-force
approach by re-running one test in an endless loop.
> I have attached a patch of AbstractIoServiceTest (against [https://github.com/apache/mina/tree/2.0])
and a stack trace. After a few loops the test is stuck. You can see a lot of threads hanging
in dispose() and the test is stuck when it tries to dispose the acceptor.
>  
> What is a little strange is that the javadoc says that connector.dispose(TRUE) should
not be called from an IoFutureListener, but in the test it is done anyway. However, changing
the parameter to FALSE does not help either.
>  
>  Is there anything that can be done to prevent this hang?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message