mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cedric Lucas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRMINA-650) Mina server does not recieve all data sent by client using SSLSocketFactory
Date Thu, 10 Dec 2009 10:22:20 GMT

    [ https://issues.apache.org/jira/browse/DIRMINA-650?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12788647#action_12788647

Cedric Lucas commented on DIRMINA-650:

I tried with multiple clients (by threading all of them) and I had some connection reset with
this piece of code.
The problem was from the creation of the socket client. So if you don't want to get into this
problem in the SSLTest.java (sometimes, it can happen), you should change the line:
factory.createSocket(parent, address.getCanonicalHostName(), "5555", true);
factory.createSocket(parent, address.getCanonicalHostName(), "5555", false);

which is the auto-close parameter

Now the test works perfectly

> Mina server does not recieve all data sent by client using SSLSocketFactory
> ---------------------------------------------------------------------------
>                 Key: DIRMINA-650
>                 URL: https://issues.apache.org/jira/browse/DIRMINA-650
>             Project: MINA
>          Issue Type: Bug
>          Components: Filter
>    Affects Versions: 1.1.7
>            Reporter: Kevin Koltzau
>            Assignee: Emmanuel Lecharny
>            Priority: Critical
>             Fix For: 2.0.0-RC2
>         Attachments: SslHandler.java, SSLTest.zip, ssltest.zip
> Using mina on the server with SSLFilter, and a client using SSLSocketFactory the server
does not recieve all
> data sent by the client.
> The client creates a socket, sends data to the server and waits for a response then closes
the socket.
> The first connection works fine, if the client then repeats on the same thread the second
attempt almost always
> fails. The server never gets all the data the client sent, and so never sends a response.
> A similar problem seems to be described in DIRMINA-580, and in fact the fix described
in [1] seems to fix the problem. However the fix that was accepted into the 1.1 branch does
not correct the problem for me.
> Attached is a test case that almost always fails (on some systems I've tried it fails
every time, others it fails 5 out of 6 times)
> [1] http://issues.apache.org/jira/browse/DIRMINA-580?focusedCommentId=12595789#action_12595789

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message