mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Bosteels" <mbosteels....@gmail.com>
Subject Re: [Poll] Naming style for acronyms
Date Mon, 17 Sep 2007 18:19:54 GMT
[x]: Only the initial letter should be capital

I agree.

On 9/17/07, Richard Wallace <rwallace@thewallacepack.net> wrote:
>
> I agree.
>
> [X]: Only the initial letter should be capital
>
> I like Davids reasoning and have some of my own as well.  The only time
> anyone actually says "input/output" is when they are answering the
> question, "What is IO?".  Similarly, the only time anyone actually says
> "Secure Socket Layer" is when answering the question, "What is SSL?"  By
> that token the acronyms have virtually become nouns in and of themselves.
>
> Aesthetically, I also just prefer to see HttpProtocolFilter,
> SmtpProtocolFitler, DnsProtocolFilter rather than HTTPProcotolFitler,
> SMTPProtocolFilter, and DNSProtocolFilter.  (There are three more
> acronyms that people never use the full names for except when explaining
> them.)
>
> But I think Davids reasoning is great because it is a practical,
> pragmatic reason to use camel case for the common acronyms (I know I've
> been bitten by this when using dependency injection).
>
> Just this mans opinion.
>
> Rich
>
> David M. Lloyd wrote:
> > On Mon, 17 Sep 2007 23:57:11 +0900
> > "Trustin Lee" <trustin@gmail.com> wrote:
> >
> >
> >> Hi folks,
> >>
> >> As many people pointed out, MINA currently has somewhat inconsistent
> >> naming style for acronyms (e.g IO vs Io and MDC vs Mdc).  I'm not sure
> >> standardizing the naming style for acronyms are definitely required,
> >> but I'd like to know what you think about it.
> >>
> >> Personally I'd prefer all capital acronym because it's what acronym
> >> is, and IOException is already a good example. :)
> >>
> >
> > Think about this though.  Say I've got a class called IPAddress.
> > Consider this:
> >
> > public class Foo {
> >     private IPAddress ipAddress;
> >
> >     public void setIPAddress(IPAddress ipAddress) { this.ipAddress =
> ipAddress; }
> >
> >     public IPAddress getIPAddress(IPAddress ipAddress) { return
> ipAddress; }
> >
> >     // other stuff...
> > }
> >
> > Many frameworks will expect that, given a property name of "ipAddress",
> there
> > will be a getter/setter of "getIpAddress/setIpAddress".  To use the
> "proper"
> > names, you'd need a property of name "iPAdress", which looks
> ridiculous.  So
> > I say, treat acronyms like words.
> >
> > So:
> >
> > [ ]: All capital
> > [X]: Only the initial letter should be capital
> >
> > - DML
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message