mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trustin Lee" <trus...@gmail.com>
Subject Re: use java 5 and retroweaver for 1.4 compatibility
Date Mon, 06 Mar 2006 02:46:48 GMT
On 3/5/06, peter royal <proyal@apache.org> wrote:
>
> On Mar 4, 2006, at 3:37 PM, peter royal wrote:
> > since MINA is targeting high-performance systems with high levels
> > of concurrency, I think it will bring the greatest value to our
> > users to use the concurrency features present in Java5 (it will
> > also help lower bugs relating to this, as there are higher-level
> > objects to deal with locking/etc).
> >
> > I propose that the RetroWeaver project <http://
> > retroweaver.sourceforge.net/> be used to provide Java 1.4
> > compatibility. It will allow usage of new language features, but
> > more importantly, usage of the concurrency bits with a bridge to
> > the backport <http://dcl.mathcs.emory.edu/util/backport-util-
> > concurrent/index.php>
>
> Retrotranslator <http://retrotranslator.sourceforge.net/> is another
> project that would help accomplish this goal as well.


I agree with you.  Actually, I was considering providing both versions.  The
problem now is how to make this work with Maven 2 so users who still uses
JDK 1.4 keep using MINA without a problem.  :)

Trustin
--
what we call human nature is actually human habit
--
http://gleamynode.net/
--
PGP key fingerprints:
* E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
* B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message