metron-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Allen <n...@nickallen.org>
Subject Re: Quick-dev-platform installation: Ambari Fatal
Date Wed, 06 Jul 2016 15:12:11 GMT
I am sorry that you are having problems.  Hopefully we can help.

I would suggest that you destroy your VM completely, remove ansible.log,
and then start over with a fresh install.  Follow the instructions
*explicitly*.  For example, I saw that you ran 'sudo run.sh' in a previous
email and in this email you mention 'run_enrichment_role.sh'.  Neither of
those are part of the deployment instructions.

If you still have problems, post your ansible.log as a Gist and send the
link, along with the exact commands that you executed, back to the mailing
list.  With the information, we might be able to help more.


On Mon, Jul 4, 2016 at 10:16 AM, Ghaleb Salah <ghaleb.salah@gmail.com>
wrote:

> Thank you Keiko,
>   I made the installation on another fresh VM, ubuntu 14.0 ansible 2.0 ,
> virtualbox 5, and got the same error. However, it continues with
> ./run_enrichment_role.sh and stops at the error:
>
> ASK [metron_streaming : Add *-site.xml files to topology jars]
>> ****************
>> changed: [node1] => (item={u'file_name': u'hbase-site.xml',
>> u'config_path': u'/etc/hbase/conf', u'jar_name':
>> u'metron-solr-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'core-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-solr-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'hdfs-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-solr-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'hbase-site.xml',
>> u'config_path': u'/etc/hbase/conf', u'jar_name':
>> u'metron-elasticsearch-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'core-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-elasticsearch-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'hdfs-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-elasticsearch-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'core-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-pcap-backend-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'hdfs-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-pcap-backend-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'hbase-site.xml',
>> u'config_path': u'/etc/hbase/conf', u'jar_name':
>> u'metron-parsers-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'core-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-parsers-0.2.0BETA.jar'})
>> changed: [node1] => (item={u'file_name': u'hdfs-site.xml',
>> u'config_path': u'/etc/hadoop/conf', u'jar_name':
>> u'metron-parsers-0.2.0BETA.jar'})
>> TASK [metron_streaming : include]
>> **********************************************
>> included:
>> /home/ghaleb/metron-latest/incubator-metron/metron-deployment/roles/metron_streaming/tasks/hdfs_filesystem.yml
>> for node1
>> TASK [metron_streaming : Create root user HDFS directory]
>> **********************
>> fatal: [node1]: FAILED! => {"changed": true, "cmd": ["hdfs", "dfs",
>> "-mkdir", "-p", "/user/root"], "delta": "0:00:07.555792", "end":
>> "2016-07-04 14:07:02.978311", "failed": true, "rc": 1, "start": "2016-07-04
>> 14:06:55.422519", "stderr": "mkdir: Call From node1/192.168.66.121 to
>> node1:8020 failed on connection exception: java.net.ConnectException:
>> Connection refused; For more details see:
>> http://wiki.apache.org/hadoop/ConnectionRefused", "stdout": "",
>> "stdout_lines": [], "warnings": []}
>>         to retry, use: --limit @../../playbooks/metron_full_install.retry
>> PLAY RECAP
>> *********************************************************************
>> node1                      : ok=62   changed=11   unreachable=0
>> failed=1
>> Ansible failed to complete successfully. Any error output should be
>> visible above. Please fix these errors and try again.
>
>
>
> Thank you for the help
>
>
> On Mon, Jul 4, 2016 at 2:02 AM, Keiko Murakami <k.murakami@nanaroq.com>
> wrote:
>
>> Hello Ghaleb
>>
>> In my experience, 2nd time run.sh showed me another result,
>> because some vagrant settings of 1st time run's remained I think.
>>
>> Anyway, the error occurred during starting hadoop cluster in
>> incubator-metron/metron-deployment/roles/ambari_config/tasks/main.yml or
>> start_hdp.yml.
>> Your hadoop failed to launch or you got timeout if your hadoop cluster
>> launched successfully.
>>
>> I got success to launch above hadoop cluster in quick-dev-platform in my
>> Ubuntu host server.
>> I modified Vagrantfile's memory setting from 8GB->6GB because of my host
>> server's max memory.
>>
>> Best regards,
>> Keiko
>>
>>
>>
>> From: g2salah@gmail.com [mailto:g2salah@gmail.com] On Behalf Of Ghaleb
>> Salah
>> Sent: Monday, July 4, 2016 7:00 AM
>> To: user@metron.incubator.apache.org; shigenobu.koufugata@gmail.com
>> Subject: Re: Quick-dev-platform installation: Ambari Fatal
>>
>> Hello Shigenobu,
>>   Thank you for your response, I have no idea why it turns into this
>> error. I cloned the master repo and running on Ubuntu 14.0 . Can you share
>> you procedure ?
>>
>> this is my result , the error drops after while not immediately.
>>
>> ghaleb@mentor:~/incubator-metron/metron-deployment/vagrant/quick-dev-platform$
>> sudo ./run.sh
>> [sudo] password for ghaleb:
>>  Running with ansible-tags: ["hdp-deploy", "metron"]
>>  Running with ansible-skip-tags: ["solr"]
>> Bringing machine 'node1' up with 'virtualbox' provider...
>> ==> node1: Checking if box 'metron/hdp-base' is up to date...
>> ==> node1: Updating /etc/hosts file on active guest machines...
>> ==> node1: Updating /etc/hosts file on host machine (password may be
>> required)...
>> ==> node1: Machine already provisioned. Run `vagrant provision` or use
>> the `--provision`
>> ==> node1: flag to force provisioning. Provisioners marked to run always
>> will still run.
>> ghaleb@mentor:~/incubator-metron/metron-deployment/vagrant/quick-dev-platform$
>> sudo vagrant provision
>> ghaleb@mentor:~/incubator-metron/metron-deployment/vagrant/quick-dev-platform$
>> sudo ./run.sh
>>  Running with ansible-tags: ["hdp-deploy", "metron"]
>>  Running with ansible-skip-tags: ["solr"]
>> Bringing machine 'node1' up with 'virtualbox' provider...
>> ==> node1: Checking if box 'metron/hdp-base' is up to date...
>> ==> node1: Updating /etc/hosts file on active guest machines...
>> ==> node1: Updating /etc/hosts file on host machine (password may be
>> required)...
>> ==> node1: Machine already provisioned. Run `vagrant provision` or use
>> the `--provision`
>> ==> node1: flag to force provisioning. Provisioners marked to run always
>> will still run.
>> ghaleb@mentor
>> :~/incubator-metron/metron-deployment/vagrant/quick-dev-platform$
>>
>> On Sun, Jul 3, 2016 at 7:11 PM, Shigenobu Koufugata <
>> shigenobu.koufugata@gmail.com> wrote:
>> Hi, Ghaleb,
>>
>> I'm not familier with vagrant and ansible, but I did get a
>> quick-dev-platform just using "sudo vagrant provision" in the last week.
>> How about try just call "sudo vagrant provision"?
>>
>> The stage of "TASK [ambari_config : Deploy cluster with Ambari;
>> http://node1:8080]" takes much time with network access.
>> Did it soon drop with that error?
>>
>> Best Regards,
>>
>> --
>> Shigenobu Koufugata
>> shigenobu.koufugata@gmail.com
>> On 2016/07/03 19:44, Ghaleb Salah wrote:
>> Hello,
>>   I'm trying to get a quick-dev-platform up and stuck with the bellow
>> error, I followed the instructions at
>> https://github.com/apache/incubator-metron/tree/master/metron-deployment/vagrant/quick-dev-platform
>>
>> Any help? Thanks!
>>
>> ghaleb@mentor:~/incubator-metron/metron-deployment/vagrant/quick-dev-platform$
>> sudo vagrant --ansible-tags="hdp-deploy,metron" provision
>>  Running with ansible-tags: ["hdp-deploy", "metron"]
>> ==> node1: Running provisioner: ansible...
>>     node1: Running ansible-playbook...
>>
>> PLAY [ec2]
>> *********************************************************************
>> skipping: no hosts matched
>>
>> PLAY [packer]
>> ******************************************************************
>> skipping: no hosts matched
>>
>> PLAY [ambari_*]
>> ****************************************************************
>>
>> TASK [setup]
>> *******************************************************************
>> ok: [node1]
>>
>> TASK [ambari_common : include]
>> *************************************************
>> included:
>> /home/ghaleb/incubator-metron/metron-deployment/roles/ambari_common/tasks/passwd_less_ssh.yml
>> for node1
>>
>> PLAY [ambari_master]
>> ***********************************************************
>>
>> TASK [setup]
>> *******************************************************************
>> ok: [node1]
>>
>> PLAY [ambari_slave]
>> ************************************************************
>>
>> TASK [setup]
>> *******************************************************************
>> ok: [node1]
>>
>> PLAY [ambari_master]
>> ***********************************************************
>>
>> TASK [setup]
>> *******************************************************************
>> ok: [node1]
>>
>> TASK [epel : Get epel-repo rpm]
>> ************************************************
>> ok: [node1]
>>
>> TASK [epel : Install epel-repo rpm]
>> ********************************************
>> ok: [node1]
>>
>> TASK [python-pip : Install python-pip]
>> *****************************************
>> ok: [node1]
>>
>> TASK [httplib2 : Install python httplib2 dependency]
>> ***************************
>> ok: [node1]
>>
>> TASK [ambari_config : include_vars]
>> ********************************************
>> ok: [node1]
>>
>> TASK [ambari_config : Install python-requests]
>> *********************************
>> ok: [node1]
>>
>> TASK [ambari_config : check if ambari-server is up on node1:8080]
>> **************
>> ok: [node1]
>>
>> TASK [ambari_config : Deploy cluster with Ambari; http://node1:8080]
>> ***********
>> fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg":
>> "value of wait_for_complete must be one of:
>> yes,on,1,true,1,True,no,off,0,false,0,False, got: True"}
>>
>> NO MORE HOSTS LEFT
>> *************************************************************
>>         to retry, use: --limit @../../playbooks/metron_full_install.retry
>>
>> PLAY RECAP
>> *********************************************************************
>> node1                      : ok=12   changed=0    unreachable=0
>> failed=1
>>
>> Ansible failed to complete successfully. Any error output should be
>> visible above. Please fix these errors and try again.
>>
>>
>> Regards
>> Ghaleb
>>
>>
>>
>>
>>
>> --
>> 0547 327 377
>> Ghaleb Salah
>>
>>
>
>
> --
> 0547 327 377
> Ghaleb Salah
>
>


-- 
Nick Allen <nick@nickallen.org>

Mime
View raw message