metron-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shigenobu Koufugata <shigenobu.koufug...@gmail.com>
Subject Re: Quick-dev-platform installation: Ambari Fatal
Date Sun, 03 Jul 2016 16:11:39 GMT
Hi, Ghaleb,

I'm not familier with vagrant and ansible, but I did get a 
quick-dev-platform just using "sudo vagrant provision" in the last week.
How about try just call "sudo vagrant provision"?

The stage of "TASK [ambari_config : Deploy cluster with Ambari; 
http://node1:8080]" takes much time with network access.
Did it soon drop with that error?

Best Regards,

-- 
Shigenobu Koufugata
shigenobu.koufugata@gmail.com

On 2016/07/03 19:44, Ghaleb Salah wrote:
> Hello,
>   I'm trying to get a quick-dev-platform up and stuck with the bellow 
> error, I followed the instructions at 
> https://github.com/apache/incubator-metron/tree/master/metron-deployment/vagrant/quick-dev-platform
>
> Any help? Thanks!
>
> ghaleb@mentor:~/incubator-metron/metron-deployment/vagrant/quick-dev-platform$ 
> sudo vagrant --ansible-tags="hdp-deploy,metron" provision
>  Running with ansible-tags: ["hdp-deploy", "metron"]
> ==> node1: Running provisioner: ansible...
>     node1: Running ansible-playbook...
>
> PLAY [ec2] 
> *********************************************************************
> skipping: no hosts matched
>
> PLAY [packer] 
> ******************************************************************
> skipping: no hosts matched
>
> PLAY [ambari_*] 
> ****************************************************************
>
> TASK [setup] 
> *******************************************************************
> ok: [node1]
>
> TASK [ambari_common : include] 
> *************************************************
> included: 
> /home/ghaleb/incubator-metron/metron-deployment/roles/ambari_common/tasks/passwd_less_ssh.yml

> for node1
>
> PLAY [ambari_master] 
> ***********************************************************
>
> TASK [setup] 
> *******************************************************************
> ok: [node1]
>
> PLAY [ambari_slave] 
> ************************************************************
>
> TASK [setup] 
> *******************************************************************
> ok: [node1]
>
> PLAY [ambari_master] 
> ***********************************************************
>
> TASK [setup] 
> *******************************************************************
> ok: [node1]
>
> TASK [epel : Get epel-repo rpm] 
> ************************************************
> ok: [node1]
>
> TASK [epel : Install epel-repo rpm] 
> ********************************************
> ok: [node1]
>
> TASK [python-pip : Install python-pip] 
> *****************************************
> ok: [node1]
>
> TASK [httplib2 : Install python httplib2 dependency] 
> ***************************
> ok: [node1]
>
> TASK [ambari_config : include_vars] 
> ********************************************
> ok: [node1]
>
> TASK [ambari_config : Install python-requests] 
> *********************************
> ok: [node1]
>
> TASK [ambari_config : check if ambari-server is up on node1:8080] 
> **************
> ok: [node1]
>
> TASK [ambari_config : Deploy cluster with Ambari; http://node1:8080] 
> ***********
> fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg": 
> "value of wait_for_complete must be one of: 
> yes,on,1,true,1,True,no,off,0,false,0,False, got: True"}
>
> NO MORE HOSTS LEFT 
> *************************************************************
>         to retry, use: --limit @../../playbooks/metron_full_install.retry
>
> PLAY RECAP 
> *********************************************************************
> node1                      : ok=12   changed=0  unreachable=0    failed=1
>
> Ansible failed to complete successfully. Any error output should be
> visible above. Please fix these errors and try again.
>
>
> Regards
> Ghaleb
>

Mime
View raw message