metron-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abid Zaidi <abidzai...@hotmail.com>
Subject Failing to Setup Apache Metron Dev Machine using Vagrant (Require Assistance and Guidance)
Date Sun, 01 Mar 2020 12:39:35 GMT
I am setting up centos7 single node VM through vagrant for Dev Environment,


I already tried centos6 from other branches and got no luck in that,

So I check out branch of METRON-2088-SUPPORT-HDP-3.1 and followed the ReadMe, before starting
I ran platform.sh and everything looked good..

On Vagrant Up it just fails on Metron_config with message

[node1]: FAILED! => {"changed": false, "msg": "Request failed with status FAILED"}

At this point I could open ambari but all services were down and each of them said the same
thing, Failed to install service, Below is the link to my logs:

https://community.cloudera.com/t5/Support-Questions/Failing-to-Setup-Apache-Metron-Dev-Machine-using-Vagrant/m-p/290740/highlight/true#M215064


This is the furthest I've come to deploying, even with the CentOS 6 I came this far,

I then also tried provision with following command,

env ANSIBLE_ARGS=' -vvvv' vagrant --ansible-tags="hdp-deploy" provision


I've done this 2-3 times and I reach to this same point,

I need to setup a Dev Environment where I could add a few more features in Apache Metron's
REST API with UI pages on the front-end. I seem to be far away from my targets as I am unable
to start up the vagrant machine, It would be good if a Metron Developer could guide me with
what I'm trying to achieve.


Regards,

Abid Zaidi.

abidzaidi7@hotmail.com



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message