metamodel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay Kumar Jalagari <jalag...@adobe.com>
Subject RE: Metamodel for java 1.7
Date Mon, 10 Oct 2016 10:24:25 GMT
Hi Kasper,

Yes, it java 7 compatible but in OSGI environment bundle start up is failing due to Build-Jdk
1.8

Regards,
Vijay Kumar J

-----Original Message-----
From: Kasper Sørensen [mailto:i.am.kasper.sorensen@gmail.com] 
Sent: Saturday, October 8, 2016 8:36 AM
To: dev@metamodel.apache.org
Subject: Re: Metamodel for java 1.7

Hi Vijay,

The pom does in deed specify Java 1.7 as both source as target. I believe that a JDK 8 compiler
will respect that also, so the output bytecode is Java 7 compatible. Have you actually tried
running MM with Java 1.7 and seen it fail, because I believe it to work.

Kasper

2016-10-07 4:56 GMT-07:00 Vijay Kumar Jalagari <jalagari@adobe.com>:

> Hi,
>
> According to metamodel source its compatible with java 1.7 but OOTB 
> jar provided by maven artifactory is java 1.8 ( Build-Jdk: 1.8.0_77 )
>
> One options is build the metamodel with 1.7 and include in required 
> other application but is there any better approach?
>
> [0] - 
> https://github.com/apache/metamodel/blob/master/pom.xml#L169-L176
>
>
> Regards,
> Vijay Kumar J
>
>
Mime
View raw message