metamodel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alberto Rodriguez <ardl...@gmail.com>
Subject Re: [DISCUSS] Java 6 support - still needed?
Date Mon, 22 Jun 2015 08:18:05 GMT
+1 to stopping Java 6 support. Last weeks we've been having some issues
with Java 6 compatibility I'm afraid that in the near future we'll be
facing more and more issues so it would be nice not supporting version 6
anymore.

Kind regards,

Alberto

2015-06-21 19:15 GMT+02:00 Henry Saputra <henry.saputra@gmail.com>:

> Let's cut one release with Java6 support and next ones with java7 or above.
>
> - Henry
>
> On Friday, June 19, 2015, Kasper Sørensen <i.am.kasper.sorensen@gmail.com>
> wrote:
>
> > Hi all,
> >
> > I am right now doing a new release (candidate) and have just run into
> some
> > SSL issues with my old Java 6 that I wanted to do the release with. The
> > particular issue is solved now, but it reminded me of the last few months
> > where we have seen tough problems with getting the build to run on Java 6
> > while many of the libraries/databases [1] we use are not even Java 6
> > compatible any more.
> >
> > So I guess my question is if we could consider stopping Java 6 support? I
> > know that we at Human Inference / Neopost have stopped supporting Java 6.
> > We could also just bump the version number and still have a old Java 6
> > compatible version and branch if needed.
> >
> > Best regards,
> > Kasper
> >
> >
> > [1] ElasticSearch, HBase, Cassandra-unit and also the Solr module (in
> > non-merged branch)
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message