metamodel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tomasz Guzialek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (METAMODEL-93) Upgrade HBase dependency to support Hadoop 2
Date Fri, 27 Mar 2015 19:55:52 GMT

    [ https://issues.apache.org/jira/browse/METAMODEL-93?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14384501#comment-14384501
] 

Tomasz Guzialek commented on METAMODEL-93:
------------------------------------------

Kasper, did you do anything more than upgrading hbase.version property to 1.0.0 and excluding
jackson-core-asl?

I managed to install and run HBase 1.0.0 on Ubuntu virtual machine. The tests fail in hbase
module:

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running org.apache.metamodel.hbase.HBaseDataContextTest
log4j:WARN No appenders could be found for logger (org.apache.hadoop.metrics2.lib.MutableMetricsFactory).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 1.772 sec <<< FAILURE!
- in org.apache.metamodel.hbase.HBaseDataContextTest
testCreateInsertQueryAndDrop(org.apache.metamodel.hbase.HBaseDataContextTest)  Time elapsed:
1.661 sec  <<< ERROR!
org.apache.hadoop.hbase.DoNotRetryIOException: java.lang.IllegalAccessError: tried to access
method com.google.common.base.Stopwatch.<init>()V from class org.apache.hadoop.hbase.zookeeper.MetaTableLocator
	at org.apache.hadoop.hbase.zookeeper.MetaTableLocator.blockUntilAvailable(MetaTableLocator.java:434)
	at org.apache.hadoop.hbase.client.ZooKeeperRegistry.getMetaRegionLocation(ZooKeeperRegistry.java:60)
	at org.apache.hadoop.hbase.client.ConnectionManager$HConnectionImplementation.locateMeta(ConnectionManager.java:1139)
	at org.apache.hadoop.hbase.client.ConnectionManager$HConnectionImplementation.locateRegion(ConnectionManager.java:1106)
	at org.apache.hadoop.hbase.client.RpcRetryingCallerWithReadReplicas.getRegionLocations(RpcRetryingCallerWithReadReplicas.java:293)
	at org.apache.hadoop.hbase.client.ScannerCallableWithReplicas.call(ScannerCallableWithReplicas.java:131)
	at org.apache.hadoop.hbase.client.ScannerCallableWithReplicas.call(ScannerCallableWithReplicas.java:56)
	at org.apache.hadoop.hbase.client.RpcRetryingCaller.callWithoutRetries(RpcRetryingCaller.java:200)
	at org.apache.hadoop.hbase.client.ClientScanner.call(ClientScanner.java:287)
	at org.apache.hadoop.hbase.client.ClientScanner.nextScanner(ClientScanner.java:267)
	at org.apache.hadoop.hbase.client.ClientScanner.initializeScannerInConstruction(ClientScanner.java:139)
	at org.apache.hadoop.hbase.client.ClientScanner.<init>(ClientScanner.java:134)
	at org.apache.hadoop.hbase.client.HTable.getScanner(HTable.java:823)
	at org.apache.hadoop.hbase.client.MetaScanner.metaScan(MetaScanner.java:187)
	at org.apache.hadoop.hbase.client.MetaScanner.metaScan(MetaScanner.java:89)
	at org.apache.hadoop.hbase.client.ConnectionManager$HConnectionImplementation.isTableAvailable(ConnectionManager.java:939)
	at org.apache.hadoop.hbase.client.HBaseAdmin.isTableAvailable(HBaseAdmin.java:1148)
	at org.apache.hadoop.hbase.client.HBaseAdmin.isTableAvailable(HBaseAdmin.java:1156)
	at org.apache.metamodel.hbase.HBaseDataContextTest.createTableNatively(HBaseDataContextTest.java:165)
	at org.apache.metamodel.hbase.HBaseDataContextTest.setUp(HBaseDataContextTest.java:49)


Results :

Tests in error: 
  HBaseDataContextTest.setUp:49->createTableNatively:165 ยป DoNotRetryIO java.lan...

Tests run: 1, Failures: 0, Errors: 1, Skipped: 0


We are enforcing guava version 18.0 while hadoop depends on guava <16.0. See https://issues.apache.org/jira/browse/HADOOP-11032
.

> Upgrade HBase dependency to support Hadoop 2
> --------------------------------------------
>
>                 Key: METAMODEL-93
>                 URL: https://issues.apache.org/jira/browse/METAMODEL-93
>             Project: Apache MetaModel
>          Issue Type: Improvement
>    Affects Versions: 4.3.0-incubating
>         Environment: Cloudera CDH 5.1.0
>            Reporter: Tomasz Guzialek
>              Labels: hadoop
>
> Current hbase-client dependency version in HBase module is 0.95.1-hadoop1. We should
consider upgrading our depedency to support Hadoop 2.
> I tried to connect to HBase in Cloudera's Quickstart VM with CDH 5.1.0 from MetaModel,
but it is using HBase 0.98.1 (Hadoop 2). I guess, many people start with this popular distribution
for a proof of concept, so ensuring that MetaModel can connect to HBase on Hadoop 2 is important.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message